Atom keeps popping up suggestions that are not helpful and I don't know how to turn it off

For instance, I am trying to coble together a fast bash script. The syntax is set to “Shell Script” but when I type stuff it is CONSTANTLY popping up this menu. Consequently if I hit enter at the end of the line it populates what I types with this stuff. I can’t figure out how the heck to turn it off and it’s driving me insane. It’s made the tool unusable at the moment.

Screen Shot 2021-03-22 at 14.37.50

Not sure if this would help your issue but I just disabled spellchecking.

In “File” menu > settings > packages, search “spell” to find the spell-check package.

Edit: Just saw another option. Search for the autocomplete-plus package. I recall disabling that one too. Reading up on these may help use them better but, to start with, I just disabled them until I had the time to dig further.