Atom just loads in white shell


#1

I tried running atom in Dev mode and it opened up in a white shell and now it won’t allow me to do anything and I receive an error.

Here is an image of what atom looks like when I load it up, I tried deleting atom and reinstalling it but same issue when I go to load it up.

Error
at new Parser (/Applications/Atom.app/Contents/Resources/app/node_modules/less-cache/node_modules/less/lib/less/parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (/Applications/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:244:16)
at LessCache.module.exports.LessCache.cssForFile (/Applications/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:275:20)
at LessCache.module.exports.LessCache.readFileSync (/Applications/Atom.app/Contents/Resources/app/node_modules/less-cache/lib/less-cache.js:263:19)
at LessCompileCache.module.exports.LessCompileCache.read (/Applications/Atom.app/Contents/Resources/app/src/less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (/Applications/Atom.app/Contents/Resources/app/src/theme-manager.js:310:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (/Applications/Atom.app/Contents/Resources/app/src/theme-manager.js:286:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (/Applications/Atom.app/Contents/Resources/app/src/theme-manager.js:203:24)
at ThemeManager.module.exports.ThemeManager.reloadBaseStylesheets (/Applications/Atom.app/Contents/Resources/app/src/theme-manager.js:266:12)
at ThemeManager.module.exports.ThemeManager.loadBaseStylesheets (/Applications/Atom.app/Contents/Resources/app/src/theme-manager.js:261:19)


#3

If that happens again in the future, it’s worth running apm links -d to see if you have any dev packages linked - it’s possible that some changes made in one of them was crashing Atom.


#5

When I ran it this appeared

Johns-Mac-Pro:~ Greenhoe$ apm links -d
/Users/Greenhoe/.atom/dev/packages (0)
└── (no links)
/Users/Greenhoe/.atom/packages (2)
├── grizzable-syntax -> /Users/Greenhoe/github/grizzable-syntax
└── test-syntax -> /Users/Greenhoe/github/test-syntax