Atom is super slow and is overprocessing


#1

Hi, I started to have this issue a month ago.

I open Atom and then I open my project folder.

My computer starts to process A LOT (I have a macBookPro 2,5GHz Intel Core i7, 16GB with macOS Sierra) … and Atom just freezes even if I’m just moving the cursor from one line to another.

This is my atom --version
Atom : 1.18.0
Electron: 1.3.15
Chrome : 52.0.2743.82
Node : 6.5.0

I have also tried uninstalling it completely, also tried atom --safe, atom --clear-window-state… but the problem remains. I have also tried uninstalling all the user packages I once installed.

I really miss Atom, what can I do ?


#2

I’m experiencing this exact issue, it’s really frustating…

I had to switch back to dreamweaver because I couldn’t really do anything on atom anymore.

My computer is also a MacbookPro with macOS Sierra, and I did too tried atom --safe.


#3

This is a shot in the dark but try running Atom as “Run as Administrator”

If the problem still persists, could you open task manager and find out what is being used up, cpu or memory?
And at what percentages/usages?


#4

I had this issue, as did a colleague. Seems to be quite common but no obvious fix. It’s weird.

We also noticed it doesn’t happen when you create a repo online and clone it.


#5

Try starting atom using

NODE_ENV=production atom .

I’ve found this improves atoms performance with 1.18. One note to be careful of, if you use a shell plugin inside atom, and use npm, that env variable will carry into the shell, so you’ll want to do the opposite inside the shell, NODE_ENV=development npm install.


#6

Experiencing the same issue, can’t use atom at the moment…
In my case the atom helper takes up most of my CPU capacity


#7

+1. Every time (well, most of the times) I switch focus back to Atom it just sits there for a 2~3 seconds before it responds to any input. Also noticed cpu usage when it’s in the background. Not super high but more than it should when it’s not supposed to do anything.

System: Windows 10, macbook pro 2015


#8

My problem is solved now…I don’t know why (?

anyway, atom is back <3


#9

Possibly - your Atom installation was updated to V1.19.


#10

indeed :slight_smile:

it’s still not working at a 100% but I have faith


#11

I have similar issue, which is every time i male changes to my stylesheet, changes only take place an hours later and some times over night, i don’t know why?