Atom . is not working in cmd

I have installed atom , but when i type the atom . to open a project i am getting
atom’ is not recognized as an internal or external command operable program or batch file.

How can i fix this issue and how can i open the atom using cmd, also when i ask for the version atom --version it is giving the same error

You need to change your PATH environment variable to include the folder Atom is installed in, which is C:\Users\<username>\AppData\Local\atom.

1 Like

I have windows 10 and ran into same issue on my windows command prompt.
DamnedScholar is correct about changing path.
For me, the path I added was: C:\Users\Owner\AppData\Local\atom\bin
Here’s a short summary on how I changed my PATH variable:

  1. Searched my computer for SystemPropertiesAdvanced.exe
  2. Clicked “Environment Variables”
  3. Edited Path for user to also include C:\Users\Owner\AppData\Local\atom\bin
    After that “atom .” opened current project
3 Likes

What if the user name is have a space between them.
My user name is “Abid shah”, and mine problem isn’t resolved even after setting the path variable.

If I remember correctly, it will work fine when using the GUI to add to the PATH variable. In the command prompt, you likely need to put it in quotes. However, you don’t have to worry if you use something like %LOCALAPPDATA%\atom\bin.

i do this and still have the same error
note :i try this (C:\Users\Owner\AppData\Local\atom\bin)
and this (C:\Users\Owner\AppData\Local\atom)

This worked magic, thank you.