Atom Is not saving files

I can’t save some files in Atom. I have the autosave-onchange package and sometimes it seems to work just fine. But, in others, even CTRL + S won’t work, and if I try to “save as” or close the file while the blue dot is still there, I receive the following message: " could not be saved. Error: undefined". Have no clues on what to do. Tried opening Atom with atom --safe, but still no result.

I use:
Ubuntu 18.04.4 LTS
Atom 1.45.0

Packages:
atom-beautify
atom-clock
autocomplete
autocomplete-java
autocomplete-modules
autosave-onchange
file-icons
ide-java
language-vue
linter
linter-eslint
minimap
python-ident

1 Like

Interesting. This has never happened to me.

You should probably create a new issue on GitHub, or – better yet – check if this issue has already been discussed before.

1 Like

Tried checking the main discussions about this on Atom Support. Most got locked for no activity. The others didn’t have a solution that worked or that I didn’t try before, so I will create a bug report on GitHub.

Hi , i am completly new to java BUT atom has being my code editor for years.
I know why your file won’t save. there is a bug when you use autocomplete-java and IDE-java
I would recommend you disable IDE-java when creating a .java file and try to crtl+s.
it should work fine.
any other file types idk at the moment but i think this should give it a fix :+1:

5 Likes

pls report this to github with giving me credit :wink:

willtricks, how would we go about disabling IDE-Java? I’ve gone through my Atom preferences, but see no options for disabling anything Java related, neither in “Editor” nor “Keybindings.”

I’m not sure I have anything Java related that’s running in Atom (I’m a newbie).

I’m having the same issue as other folks—I can’t “save” and I can’t “save as”