Atom is entering an extra quote?


#1

I have found when using the autocomplete-plus package. Let me give you a situation.

I type <link and then press “r” it gives me the list of possible inputs and the one I want of course is “rel”. I go down to rel and press enter and it displays re="". This is fair and works as should but when I type “stylesheet” and put in my ending quote it adds ANOTHER quote. It behaves as if it doesn’t recongise that I am already in the middle of two quotes.

I have narrowed this down and found that the reason is autocomplete-plus and the fact it preemptively enters the “” for the user but I don’t want to disable autocomplete-plus because I find it very useful.

Anyone know how to solve this issue?


#2

autocomplete-plus doesn’t deal well when punctuation is used as part of the prefix of a snippet. If that’s what you’re doing, then I would recommend using only alpha characters for the prefix. There are also some improvements coming to bracket-matcher (which is the package that handles the bracket and quote completion) in v1.16 that may make things better.