"Atom" is damaged and can't be opened


#1

Hello all,
I’m trying to install Atom from the downloaded zip file. When I extract the Atom.app and try to open it, I get the following:

“Atom” is damaged and can’t be opened. You should move it to the Trash.

I’ve tried extracting and then moving the Atom.app to /Applications and I’ve tried extracting Atom.app directly to /Applications. I’m running OS X 10.9.1. I searched the forums and haven’t seen anything about this. Any help would be appreciated.

Take care,

Jeremy


#2

Did you try redownloading?


#3

nikolaus,
Of course I did. I even mentioned above how I tried different extraction methods.

Take care,

Jeremy


#4

I had the same problem when I unzipped from command line using unzip, then I tried using The Unarchiver app and it worked.


#5

@AbeEstrada nailed it. While I didn’t have to use The Unarchiver app, I was able to use the built-in archive support in OS X which I guess is different than the CLI utilities that come with OS X. That being said, using unzip atom-mac.zip created a damaged Atom.app but using open atom-mac.zip worked. (You could also double-click atom-mac.zip from within Finder to achieve the same working result.) This might be worth mentioning in a README or something.


Unable to Expand Error 35
#6

Thanks for the report guys. I’ve filed an issue and we’ll be looking into it shortly. Has this changed with newer releases of Atom? I wonder if it’s a Mavericks thing. I’ve been to busy to upgrade and I’ve never had issues unarchiving.


#7

I downloaded from atom.io the zip (0.67.0) and tested unzip atom-mac.zip, still damaged on OS X 10.9.2


#8

I had the same problem. The Chrome somehow corrupts the zip archive. I solved the problem by downloading with Safari.


#9

Firefox too, for what it’s worth.


#10

I just had this problem, and it looks like it hasn’t been discussed here in a long time. Using open on the command line worked for me, but having to do that is a counterintuitive surprise.

Suggestion…since this file is only to be used on a Mac, why not use a tar file instead of a zip file so that it will work ok on the command line (with tar)?


#11

The problem mentioned above was that the unzip command did not work, while double-clicking the file in the UI worked just fine. I just did:

  1. Launched Chrome
  2. Navigated to https://github.com/atom/atom/releases
  3. Downloaded v0.158.0 from https://github.com/atom/atom/releases/download/v0.158.0/atom-mac.zip
  4. Went to my Downloads folder
  5. Double-clicked atom-mac.zip
  6. Moved Atom.app to /Applications
  7. Double-clicked Atom.app
  8. Clicked “Yes, really … I want to open this” button

Atom opened just fine for me. How did you attempt to install it @keithrbennett?


#12

As I said, using open on the command line worked for me.

I was merely suggesting an alternate strategy that might be more friendly to command line users.

Thanks,
Keith


#13

Ah ok, sorry for the misunderstanding.


#14

Update: unzip atom-mac.zip still creates a damaged .dmg


#15

I had the same issue, working on Mac Pro (Early 2009) OS X Yosemite. I tried using B1 unzip the file but the program kept on crashing. I tried using Terminal on mac to unzip and got the same message “damaged and can’t opened”. Solution use sudo sudo unzip atom-mac.zip that worked for me.

Best,

gil


#16

Unzip from the command line often leads to unusable Mac applications. Something about permissions or something, I forget.

Therefore, why not simply use the built-in utility for unzipping files? I don’t get it.


#19

Having the same problem with Atom 1.0 on Yosemite. Downloaded multiple times with different Browsers.
I cannot make it work with:

  • OS X “doubleclick” unzipper
  • Command line unzipping
  • TheUrarchiver
  • Keka

:frowning:

fyi:
$ shasum -p atom-mac.zip 03be618d322573838d69fe19d2477c87e4511e30 ?atom-mac.zip


#20

Aha, the problem was, that i was unzippig it to a HD thats not HFS+, but exfat (my download-dir is on a harddisk rather than on my ssd).
After moving the .zip to a HFS±Partition, I was able to unzip and launch it.
Thats really strange.


#21

Hi there,

I am having the same issue.
macOS Sierra 10.12.5 Beta (16F71b)

When I use the standard unzip tool of OSX the file gets extracted but OSX tells me it is corrupt.
The same error appears when I use

unzip atom-mac.zip
or
open atom-mac.zip
in the terminal

When I use

sudo unzip atom-mac.zip
or
sudo open atom-mac.zip
it crashes or I get the same error.

Crashed Thread: 0 Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Exception Note: EXC_CORPSE_NOTIFY Termination Reason: DYLD, [0x5] Code Signature

When I use “The Unarchiver” the extraction process stops with the error that the file “Atom.app/Contents/Frameworks/Electron Framework.framework/Versions/A/Electron Framework” has a wrong checksum and could not be extracted

My harddisk is formatted with “Mac OS Extended (Journaled, Encrypted)”

Can anyone help?


#22

I also get this: Crashed Thread: 0 Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000 Exception Note: EXC_CORPSE_NOTIFY Termination Reason: DYLD, [0x5] Code Signature