Atom.io freezes up a lot on file change. Also crashes every time it's side by side in windows 10


#1

Every time without fail, moving Atom into the Windows side by side split screen mode, the cursor stops blinking, and appears stuck. I cannot insert any text or change tabs, or open settings or anything. Doesn’t seem to matter which side of the screen it’s on, or what other application is open. Not sure what’s going on here. I’ve tried uninstalls and reinstalls, as well as running atom --safe to avail.

I’ve also been experiencing a seemingly increased amount of freezes, that aren’t related to docking the window in side by side mode. It seems to happen when I am editing and saving files, opening new ones, or expanding a folder hierarchy.

I really enjoy the look and feel of Atom, but I simply cannot function with these issues. Last night when I was trying to change a few lines of code around, it crashed on me after every change, and I was constantly having to restart it.

Similar topics mention it could be package related. This is on a fresh install, with only the 78 core packages it comes with. No other settings have been changed.

Thanks for taking the time to read my post. Hopefully someone can come to the rescue!


Atom crashes when current file in buffer is overwritten/updated
#2

I believe this is being tracked here:

There is an issue being tracked down right now that has to do with how Atom indexes the Git repository when the directory opened isn’t a Git repository (but one exists higher up the directory tree). This might be the cause of your issue, if my description sounds like it might apply.


#3

Ah, thank you. Glad to see I’m not the only one having the problem with the windows snap issue.

Also I was wondering if it had to do with Git myself. Again, glad to see I’m not the only one!

Hope it all gets fixed soon! For now, I think I’ll use another edit and save myself some frustration. Hopefully next time I choose Atom, all will be smooth again!


#4

I recently setup Ubuntu on a virtual machine, and tried running atom in there. Appears it becomes unresponsive as well, with no extra packages installed. I even tried to disable the git related core packages, still having the same issue with it becoming unresponsive when I expand a folder, open a file, or click through few different files quickly. I can’t seem to pinpoint what causes it to become unresponsive exactly as it seems to random to me still, but the last time it happened was when I went to expand a folder and open a file. Expanding the folder I think is what caused the freeze.

Had just read your post again, so I thought I’d provide more info. I noticed you said it was an issue with non Git repositories, but mine are. The files I was working that caused the last freeze was inside of a repository, and also being tracked.

So I am having the same exact issues on both Windows and on Ubuntu. Just thought I would post in case it can potentially help someone track the bug down.

Hopefully it’s fixed soon, I really would like to continue using Atom, as Brackets just isn’t cutting it for me, and I can’t afford Sublime. :slightly_smiling:


#5

Are they the same files? Are you running on the local drive in each case?


#6

Same project, but it’s not one particular file or folder that seems to be the issue. And yes, they are both stored on this box.


#7

The only thing that I can think of that would be common in the two situations is your project. Does it happen with some other arbitrary files?

So you are using some sort of networked file-sharing? I would try it without that. Put the project in a local folder and see if you can recreate the problem.


#8

No, they are local, no networked file-sharing of any kind is going on. On windows it is stored locally on the HDD, and in the virtual machine it is cloned locally into the virtual drive.

Also I meant it isn’t one particular file or folder inside of my project to clarify.


#9

Are the VM and windows sharing a common directory? That could present similar problems as network file sharing. Again, try it on different files in a non-shared directory. I’m not suggesting this is a work-around, just a test.

There has to be something different in your setup since there are a zillion others running the same version of atom without your symptoms.


#10

No, they are not sharing a common directory. The project on the windows isn’t even up to date, I could delete it and it wouldn’t effect my VM directory in any way.


#11

I’m seeing this behavior as well. Atom 1.3.2 on CentOS 7. I was seeing it prior to establishing a repo for my files, and continue seeing it after init-ing them. I’ve left a frozen instance alone for over 24 hours previously, and it did not recover. Other running instances were not affected by a separate frozen instance. I didn’t observe it at all until I was clicking back and forth between multiple files quickly, and that seems to be the most consistent method to reproduce it. I did notice that it was not as frequent when I uninstalled the git community plugins I had installed, but it is still present. Currently, the only plugin I have installed is imdone.

I was able to reproduce just now in safe mode by clicking through and opening several files (9 tabs, including settings, open currently). The files are all small (ansible playbooks), and this is what I see in top (atom in safe mode, currently frozen):

top - 10:34:29 up 10 days,  2:41,  4 users,  load average: 1.62, 1.03, 0.70
Tasks: 315 total,   2 running, 313 sleeping,   0 stopped,   0 zombie
%Cpu(s): 14.2 us,  0.6 sy,  0.0 ni, 84.9 id,  0.2 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :  7993188 total,   319264 free,  3668696 used,  4005228 buff/cache
KiB Swap:  8257532 total,  8257420 free,      112 used.  3760964 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                               
16701 jwelch    20   0 1356080 195720  55644 R 100.3  2.4   5:53.06 atom

#12

I can’t find the Issue right now, but this was reported recently and is being tracked as an Issue as far as I can recall.