Atom.io fails for ppc64le(power machine)


#1

steps performed
sudo apt-get install build-essential git libgnome-keyring-dev fakeroot
sudo update-alternatives --install /usr/bin/node node /usr/bin/nodejs 10
git clone https://github.com/atom/atom
cd atom
git fetch -p
git checkout $(git describe --tags git rev-list --tags --max-count=1)
output of script/build

Node: v0.10.25
npm: v2.13.3
Installing build modules…
Installing apm…
download not found: http://nodejs.org/dist/v0.10.40/node-v0.10.40-linux-ppc64.tar.gz
npm ERR! Linux 4.2.0-18-generic
npm ERR! argv “node” “/home/Atom/atom/build/node_modules/.bin/npm” “–userconfig=/home/Atom/atom/build/.npmrc” “–target=0.10.35” “install” “–loglevel” "error"
npm ERR! node v0.10.25
npm ERR! npm v2.13.3
npm ERR! code ELIFECYCLE

npm ERR! atom-package-manager@1.4.1 install: node ./script/download-node.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the atom-package-manager@1.4.1 install script ‘node ./script/download-node.js’.
npm ERR! This is most likely a problem with the atom-package-manager package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./script/download-node.js
npm ERR! You can get their info via:
npm ERR! npm owner ls atom-package-manager
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/Atom/atom/apm/npm-debug.log


#2

Atom doesn’t support PowerPC processors out of the box. I don’t know of anyone here that has experience with PowerPC systems that could help you.


#3

thanks for your reply . however what is exact error ? whether its npm or nodejs error


#4

I don’t know that anyone has even done enough work to find out what the error would be :grinning: