Atom infected by redirecting malware?


#1

Hello,
I’m making my first steps in php. I use Atom but when I tried to create a redirecting page like this ->


I got redirected to a number of websites. I tried to locate the error and I noticed that the redirecting-behaviour happens only with Atom-files, I tried TextWrangler and Brackets, both act normal.

I’m kind a confused since I thought source code was the only thing browser was getting but apparently something is happening beyond my sight.

Any idea in which file I have to look to find the error ?

Will uninstalling & reinstalling (I like Atom a lot) solve the problem as well ?

Any more info is more then welcome.

yt

Wom


#2

Apparently there is no code allowed…
form action = “http://www.google.be/search” method=“get”

input name=“q” type=“text”

input type=“submit” value=“google search”


#3

Code is allowed. You just have to highlight it and press the </> button above the editor to tell the forum that it’s code.

Please provide a precise description of how to replicate the error, with bullet points that describe every single step between creating a blank PHP file and observing the weird redirect behavior so that anyone who decides to help you out can observe it for themselves. What does “a number of websites” mean? What constitutes an “Atom-file”? What are you using to check your code once you’ve written it? What is the normal behavior? Are you using a different PHP server with Atom compared to the other editors?

It’s highly unlikely that Atom is infected by malware that specifically taints one particular operation in PHP files.


#4

steps : Started from zero and typed in the code below, first page(invulpagina.php) being a page where you give a name, submit brings you to second page (welkom.php).

number of websites : I see a number of websites appear at high speed, it’s not a redirect to one adress but rather like it’s flashing from one to another aso for a few secs, the endresult goes from adultcontent to toyshops for kids.

Atom file = = file created with Atom

Checking code = checked it on Opera, Firefox Developer, Safari & Chrome
Checked it on Mamp local. (MacOS Sierra 10.12.6)
Checked it on external server with other device (Samsung phone) /same behaviour

Retyped the code in TextWrangler, no problem anywhere. //I don’t understand.
Same server Mamp, same folder, same browsers.

<!DOCTYPE html>
<html>
<head>
<title>invulpagina</title>
<meta charset="utf-8">
</head>
<body>
  <form method="post" action="welkom.php">
  Uw voornaam :
  <input type="text" name="Voornaam">
  <p>
  <input type="submit" value="Verzenden">
</form>
</body>
</html>
<html>
<head>
<title>Welkom !</title>
<meta charset="utf-8">
</head>
<body>
  <h2><?php print"Welkom, ". $_POST['Voornaam']?></h2>

<br>
<h2>zoek dat eens op op google</h2>
<form action="http://www.googe.be/search" method="get">
<strong>Zoek op het web </strong>
<p>
  <input name="q" type="text">
  <br>
  <input type="submit" value="Zoeken met Google">
</body>
</html>

#5

perhaps a typo?