Atom ignoring some settings?


#1

I’m having problems with atom on Mac OS Sierra. Atom version ist 1.18.0.
It seems to be ignoring some settings. For example: I’ve selected “restore previous windows on start: yes” but Atom always comes up with no editor tabs open.
I also added a bunch of filetypes to the ignored names and activated “hide ignored names” in the treeview settings. But the files that should be ignored still show up in treeview.
I’ve got a linux machine with the same settings and everything is working perfectly. Am I missing something?
Any help is greatly appreciated.


#2

Do you have the same packages installed on both machines? What happens if you start atom in safe mode?


#3

I have language-latex and minimap packages installed on both machines.

I’ve tried running
atom --safe
from terminal but that doesn’t change anything besides that minimap is gone and there’s no LaTeX code highlighting anymore. So I guess it doesn’t have anything to do with these two packages.


#4

Did you try checking the values stored in the config.cson file? Are they the same as you would expect?


#5

As far as I can tell, the values are correct. Some examples:

> openEmptyEditorOnStart: false
> hideIgnoredNames: true


#6

I’m possibly having the same issue as @landflucht on MacOS Sierra. The difference is that my other system is a Windows 10 laptop and not Linux.

Originally I was coding and hosting from the Mac and Atom worked as expected (on both systems), but I recently installed a NAS and I’m hosting from that system. I have Atom (1.18 and latest 1.19 Beta tested) loading the network share in both cases and still works perfectly from the Windows system, but the Mac no longer hides files that I list. Both versions have the exact same packages with the same settings (except mount location). I went as far as thinking my copy of Atom on the Mac was somehow corrupt, deleted it (and it’s hidden directories/files) and started from scratch making sure everything matched.

It doesn’t sound like @landflucht is editing network accessed files though like I am.


#7

It doesn’t sound like @landflucht is editing network accessed files though like I am.

That’s correct. My project directory is local.

@Archigos do you also have the issue with Atom not opening the previously opened tabs?


#8

It’s happened a few times since I switched to the network share, but it only happens when I open Atom and am having network issues (like the wifi isi down) and didn’t notice.