Atom IDE and linter package together?


#1

Hi everyone,

I really like the look and feel of Atom IDE! However, I’d occasionally like to use packages that require the linter package, such as linter-gcc for instance.
Now, when both linter and atom-ide-ui are installed, Atom gives me the message

You have both linter and atom-ide-diagnostics enabled, which will both display lint results for Linter-based packages.
To avoid duplicate results, please disable one of the packages.

Which suggest, that I could use atom-ide-diagnostics as a substitute for linter. Is that true? Can I have my linter-gcc messages shown in atom-ide-diagnostics?
Otherwise, has someone come up with a solution to have both linter and atom-ide-ui installed?


#2

Hello.

Currently the Atom IDE functionality is listed for the following grammars:
https://github.com/atom/atom-languageclient/wiki/List-of-Atom-packages-using-Atom-LanguageClient

Are you currently using the Atom IDE functionality?
…you are developing C++ code - right?

As the message in Atom suggests, you can deactivate a package if you are not using it.
For example, I have two Python grammar packages. The built-in grammar package is deactivated as not to compete against the community driven package.

Consider deactivating the IDE functionality until the guys have a language client that will benefit you.
…or such is my novice opinion.

Regards.


#3

Since version 0.5.2 Atom IDE supports Linter V2 packages! So my issue is fixed :blush:


#4

Well, I installed the latest version of atom-ide-ui and linter-gcc, but it doesn’t work. The linter messages can not be shown until I disable atom-ide-diagnostics and enable linter/linter-ui-default.
Can you show me how to deal with it?

Thanks.


#5

I can’t get it to work anymore, either! I switched back to using linter just for this reason.

The package-switch package, helps me to switch from linter to Atom IDE easily.
Sadly, this is not the best solution. We may hope for ìde-cpp to become stable.


#7

It seems fixed! I’ve just enabled linter-twig, while the linter plugin itself is disabled and …of course atom ide enabled.


#8

One thing to note on this that I’ve just found is that you need to make sure that you enable:

Diagnostics Services

in the atom-ide-ui settings. I had disabled it as I used Linter and have just switched back (as you don’t need both now) and it wasn’t showing anything. That was why :slight_smile: