Atom icon disappearing from macOS dock


#1

Hi,

Over the last few days I’ve enountered an issue where the Atom icon in my dock keeps reverting to a question mark after I log out and log back in. The icon also no longer launches Atom when I click it (nothing happens).

Here’s a screenshot of the dock:

I’ve tried removing it from the dock and re-adding it, reinstalling atom, deleting ~/.atom/storage but none of those have helped. I’m not sure what else to try. Has anyone else seen this and have a solution?

Atom version is 1.12.7, I’m on macOS Sierra 10.12.2

Thanks!
Andrew.


#2

How did you install Atom? Did you download the zip from the Atom main page, or did you use brew cask?


#3

I downloaded the zip and extracted it into /Applications


#4

Are you sure you dragged the application icon in the dock, and not the installer? Once the installer is deleted, the icon would turn into a question mark.


#5

I launched it from Spotlight and while it was open dragged the icon into the position I wanted it to be in my dock. Next reboot, it was a question mark. Have tried this a number of times.
Just can’t work it out - this has worked for me in the past. Maybe something is hosed on my machine and it’s nothing to do with Atom at all, is nobody else is having the same issue.


#6

It could be possible that the icon you pinned (after launching Atom) was associated with a specific version of Atom, then after it updated, the asset in the old directory was deleted and your OS had no idea where to find it. Try dragging atom.app straight to the Dock.


#7

Or launch Atom, right-click the icon, highlight Options and select “Keep In Dock”:


#8

Unfortunately same behaviour when trying it that way. Thanks for the suggestion though


#9

same behaviour for me!


#10

Yeah, I’m having the same problem - I’ve dragged the app directly from the applications folder every time, and it disappears after a reboot more often than not. No clue what causes it, it seems to be random to me. Does anyone have any other ideas as to why this is happening?


#11

I am having the exact same issue. Has anyone figured out what is causing it and how to fix it?


#12

I have the same issue, does anybody know how to fix it?
Btw, it also happens with SourceTree application


#13

I have the same issue but with the Postman ‘native’ app which is also Electron based… maybe the root of the problem is there? Is SourceTree also Electron based?


#14

This is an old thread but it might be worth sharing my solution. I downloaded the install from atom.io to the Downloads folder and double clicked the file. Rather than installing it, it just ran Atom and I thought it was installed and added it to the dock. It wasn’t. I did a macOS update and restart. After that, the Atom icon was gone from the dock. In its place was a question mark.

The solution was to go to my downloads folder and drag the app into Applications.


#15

As others mention, if you downloaded Atom into your downloads folder and either double-clicked it or dragged it to your dock, you will end up in trouble like myself and others here, as when you empty the downloads folder later on, the Atom app disappears with everything else. I was unlucky that I emptied my trash too and really lost it!

The correct way is to download the app into your downloads folder and immediately drag it to your Applications folder, then you can drag it to your dock from there.

To fix this problem, I simply downloaded another app from the Atom site, moved it to Applications properly, and luckily it remembered all my settings and installations/plugins and was ready to go as it was before I deleted it. Thank you for making that possible, Atom. I was ready to throw my computer out of the window knowing I lost all that setup work.