Atom helper usage CPU 100% and not respond


#1

Hi all,
I have a big problem,
My atom editor can’t use because atom helper hogging all CPU,


Below is my computer& atom plugin’s information:

Macbook Pro (2015)

  • System version: 10.12
  • Memory: 16GB

Atom version: 1.14.4

  • Install Plugin: emmet (Yes, I just install emmet…)

Could anyone help me ?
I stuck five days… :cry:


#2

Have you followed the suggestions in the Debugging document? Also, can you reproduce the issue after completely exiting Atom and restarting using atom --safe? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

Hi leedohm,
I try safe mode already, but atom also crach again and again…
and finaly, I delete emmet too, but this problem still is not solved…


#4

Have you tried the other steps in the debugging document? There are a lot of things to try in there and I’d rather not have to suggest each one individually :wink:


#5

In have the same problem

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND     
26242 xxx       20   0 1369476 317904 127560 S  96,4  3,9   0:15.33 atom   

The problem has been fixed resetting to default factory values and restarting again.

$ mv ~/.atom ~/.atom-backup

I hope this helps anyone.