Atom Helper, Mac, hogging all CPU!


#1

Hi,

I LOVE this editor however I’m noticing performance issues and opening up Activity Monitor I notice Atom Helper using 101.5% of the CPU.
I am at the latest version 1.3.2
Please help!

.

Peter


#2

Here is some quite relevant discussion about this issue. It is a long thread:


#3

Thanks for the link!
The title link give me a 404 however https://github.com/atom/atom/issues/3426 works.
I am also on a MacBook pro - I edited the same file on my iMac last week with no issues.


#4

There’s all kinds of things that can cause this issue. Have you tried running Atom in Safe Mode?

To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have Emmet installed?

#5

Hi Leedholm.

Sorry to take so long to reply to this post.

I found that what finally worked was from a long thread on the topic directing to “Force quit Atom Helper through the Activity Monitor, then quitting Atom, then starting back up again”. This resolved the issue for a goo long period of time. It’s rare, but it will occasionally happen again, so I just go through the process.

To answer your questions, Atom version 1.4.3, Mac OSX 10.11.3, I do have Emmet installed.

The Safe mode option didn’t work, the helper still hogged everything up.

Thank you!
Peter