Atom Helper High CPU - Disabled Git Packages

Macbook Pro Early 2015
macOS Mojave Version: 10.14.2

apm 2.1.3
npm 6.2.0
node 8.9.3 x64
atom 1.34.0
python 2.7.10
git 2.20.1

I’ve found this topic in many threads with no definite answer as to how to properly fix it. When I run atom, I am getting a 100%-135% CPU usage with Atom Helper when running Atom. I have tried the following:

  • Clean uninstall & reinstall of Atom
  • Tried all steps in the debugging documentation
  • Disabled all community packages
  • Restored Atom to default settings

None of those steps made any changes.

I then decided to disable the following core packages involving Git:

32%20PM

Once I disabled these four packages, the CPU usage dropped to 10%-12%.

I’m glad I was able to fix my issue because it allows me to get back to work but it doesn’t really solve the issue. How can I fix this issue where I’m not obligated to disable core packages?

Thanks in advance for any help on this issue!

When you have the github package enabled, do you see a very large number where the 19 is?

Wow it’s a lot…79248

Then there’s a git repo somewhere in your folder structure that doesn’t have a .gitignore. Most likely, you created it by accident and have a large folder like ~ or Desktop open. You should look for .git/ folders in places that you don’t expect to be repositories (if you have hidden files obscured, then you might have to make them visible). If there is one in a place that you’ve never used as a repo, you can safely delete it.

1 Like

Thank you so much for your help on this! I had a local git repository within my username folder so after deleting that, it cleared everything up! Appreciate it a bunch!

Yep, that did it for me! I had a .git exactly where you suggested in my /userfolder. Indeed I had to make the hidden files show in order to see it [shift cmd . (period)].
Thanks DamnedScholar.