Atom Hacktable Installation Problems -


#1

Hello . I need your help .

atom --safe not working . ScreenShot :

Error Post : ‘atom’ is not recognized as an internal or external command , operable program or batch file .

I’ve used cmd > atom --safe

I did not delete and tried again . But not working .

Help me . I need your help .


#2

Please post a screenshot of what you see in AppData/Local/atom/. Sometimes the commands don’t get installed correctly, in which case you may have run into this issue:

Please try the workaround provided and tell me if that works. Open the command line and cd to the folder Atom is installed in, then run:

atom --squirrel-updated

It should create a folder called bin/ with four files in it. If that doesn’t work, you can download copies of those files from here and create the folder yourself and that will work (you may need to add that folder to your Path if it isn’t there already.)

To fix the issue where Atom fails to load, you can try renaming the .atom/ folder in your user directory. That will be effectively the same as running atom --safe.


#3

Not working :frowning: .
When I write this screen :

apm.cmd in writing ,
@echo off
"%~dp0…\app-1.34.0\resources\app\apm\bin\apm.cmd" %*

Still Same

PC : x64 Bit
Atom Setup = x64 Bit


#4

Screenshot_3


#5

Screenshot_5


#6

You need to rename the .atom/ folder, not go inside it.


#7

I did not understand . Is video or a good source available ?
Or can you explain in more detail ?


#8

Open your user folder in Windows Explorer and right-click on .atom/. Select Rename, then type atom-backup.


#9

I did that, but it didn’t work.
Screenshot_1


#10

Okay. Now, try atom --clear-window-state.


#11

I tried but the result is the same


#12

Please help . I need your help .

:frowning:


#13

You didn’t enter what I gave you. It’s --clear-window-state.

What do you see at the top of the red error message displayed in Atom?


#14

I tried that command


#15

Hey bro !
Can’t you give me another solution ?

Please . This editor is necessary for me .


#16

Have you tried deleting the AppData/Local/atom/ folder and reinstalling?

If that doesn’t work, you should try downloading atom-x64-windows.zip from this page, unzip it, and see if the atom.exe inside it works.


#17

I am trying


#18

Not working :frowning: :sob::cry:


#19

Okay, I want you to try something weird: move that folder off of your desktop and outside of your user folder. You can put it in C:/ or on another drive or anywhere else except the protected folders (that might cause another bug). It might be that the special characters in your username are causing trouble for the filename resolution when Atom starts up.


#20

Thanks :slightly_smiling_face:
Atom is currently working

USB Disk installation . F:\


'C:\Users\"USERNAME"' is not recognized as an internal or external command, operable program or batch file. The system cannot find the path specified