Atom/Git on Windows 10: where to enter user name and email?


#1

I am new to Atom; installed it on Windows 10 today… wanted to use GIT…
I selected: Packages | GitHub | Toggle Git Tab
moved the unstaged files to staged
entered a comment and hit commit
An error pops up that my user.name and email are not configured.

*** Please tell me who you are.
Run
  git config --global user.email "you@example.com"
  git config --global user.name "Your Name"

I could not find the GIT config file.
The terminal would not accept the commands:.

Searched this forum, but did not find a useful answer.

I then installed the package Git:plus
… hoping to get further.

Now I am stuck.
Any help appreciated.


#2

Which terminal? What does “not accept” mean? If an error, what was the error?

Did you run the commands in the command prompt? Did you replace the parts between quotes with the correct information? E.g., the second might be

git config --global user.name "Max G"

This forum is for Atom and Electron related topics. We’ll normally do our best to help with whatever, but you can’t expect anyone here to be able to help. Git is a program in it’s own right, and not something introduced by Atom.

My guess is Git doesn’t work at all for you, even directly in the command prompt. You’ll need to get that sorted before it will work in Atom.


#3

I was going to amend my post, but I had no edit function on the first post.

I used the PlatformIO terminal (which is a powershell) which returned:
unknown commands
… which I believe to be related to the PATH variable not containing a reference to GIT

I then red the git config command in a command prompt.
Same result: command not found because GIT not in path.

I came to this forum because it seems to come with GIT functionality, hence, the forum would know where to find the git.exe (which I can’t find), or whether I need to install something extra.

Are you saying that GIT itself needs to be installed before it can work with Atom?


#4

Alright… install git was hint that worked…

For the benefit of other, this link will show the complete background to the problem:

the solution to my problem:
installed git
it came with Git-bash
ran:
git config --global user.email "you@example.com"
git config --global user.name “Your Name”

then
git config --list --show-origin
… which shows the complete config file

here an extract which shows the config location:
file:“C:\ProgramData/Git/config” core.symlinks=false
file:“C:\ProgramData/Git/config” core.autocrlf=true
file:“C:\ProgramData/Git/config” core.fscache=true

Case closed :smile: