Atom getting super slow, is there any way to recode the slow log?


#1

MacOS Mojave using atom latest version.
the Atom helper make cpu > 70%, I have no idea what’s wrong with it, is there any way to checkout which plugin or why Atom getting slow?
I just can’t work with it anymore.


#2

You could start with safe mode - that would at least confirm that it’s likely a community package is causing the issue. If you don’t see a problem in safe mode, then it might be something else (the particular project you’re working on, etc.).

If things do work ok in safe mode, you can disable all your community packages and then re-enable them one at a time to try and pinpoint the problem.


#3

I only installed ex-mod and vim-mode


#4

So there was no difference in safe mode?

Some other questions:

  • Are you working on a specific project when you see this behavior or it doesn’t matter what project you’re working on?
  • What specific version of Atom are you running (atom -v)?
  • Have you always seen this behavior or is it new with the version of Atom you’re running?
  • Do you have a .git directory in your home directory (ls -ld ~/.git)?

#5

Are you working on a specific project when you see this behavior or it doesn’t matter what project you’re working on?

// all project

What specific version of Atom are you running (atom -v)?

Atom : 1.33.1

Electron: 2.0.16

Chrome : 61.0.3163.100

Node : 8.9.3

Have you always seen this behavior or is it new with the version of Atom you’re running?

// always see this

Do you have a .git directory in your home directory (ls -ld ~/.git)?

// nope

Robert Sese github_atom@discoursemail.com 于2019年1月3日周四 上午11:49写道:


#6

// all project

What if you have no projects open and just a blank Atom window?

// always see this

From what specific versions of Atom? Just wondering if you seen this for a long time or just since a particular version of Atom.

And just to ask again, so there was no difference in safe mode?

Lastly, does temporarily resetting to factory defaults make any difference?

https://flight-manual.atom.io/hacking-atom/sections/debugging/#reset-to-factory-defaults