Atom gets stuck while opening any file


#1

I updated to Atom 1.2.0 today. Now, I seem to have a really weird problem. Whenever I try to open a file in the editor, it just hangs for a while and finally asks me whether the editor should be closed (it only happens in local repos). I’ve tried removing all the packages, tried safe mode, tried reinstalling Atom, but nothing seems to work. I don’t even understand what’s wrong all of a sudden. Can someone help me?

Atom version: 1.2.0
Platform: Ubuntu 14.04 (x64)


#2

Can you please try to quit all Atom instances and remove (or rename) ~/.atom/storage?


#3

I did. Nothing happened. I’d even removed the entire ~/.atom folder, which also didn’t have an effect. Also, I just found that this occurs only when I try to open files in local repos. Normal files work just fine…


#4

Everyone! I just realized that I’m experiencing the problem only with 1.2.0. I’ve fallen back to 1.0.19 and I don’t have any issues with it.


#5

Ah yes, I’ve heard more people having issues lately when git repositories are involved. If only I knew where I saw that :confused: By the way, is that v1.2.0 or v1.1.0? Because earlier you were talking about the latter


#6

Is it this one?


#7

Oh, I’m sorry for the confusion. Only 1.2.0 has issues. I’d updated 1.1.0 to 1.2.0.


#8

Yes it is, but not quite. It crashes whenever we try to open any file in a local repo.


#9

In any local repo? Or a specific local repo?


#10

Maybe this one:


#11

It happened to all repos


#12

I’m not sure. As far as I can recall, it happened for all the files (even markdowns and text documents), but only in local repos. It doesn’t happen when I open something outside a repo.


#13

The bug pointed exist for repo with large number of file.
(In particular repo can have a large number of imported/generated files, eg node_modules)

if your issue happens in a new very small repo, then it’s probably somehting diffferent work looking into.


#14

@leedohm @Maxim No, it was this one (which has actually been around for a long (long) time but still quite active):


#15

I updated lately, and Atom works fine now. Thank you all for your responses :slight_smile: