Atom generally slow at opening files


#1

I had this open before, then thought maybe it was the minimap plugin slowing me down, submitted a ticket there but then I came to the conclusion it probably wasn’t.

I’m including a screenshot of my profile which shows how much idle is going on when opening files. It even happens when I try to open tiny files, and my best guess now is that it’s related to the size of the project folders (at times I have 8gb or more open). However, I can’t explain why atom would be idle, instead of just open the file I need. So again, any help would be nice!


#2

The CPU profiler can only capture things going on in the renderer process. If things are going on in background processes (such as anything to do with Git), that time will show as “Idle”. I’m assuming that you’re opening a new window for a specific file in the above screenshot?

Also, it appears that you’re only showing memory usage rather than a CPU profile in that screenshot. It is hard to judge activity from memory fluctuations.


#3

You’re assuming correct, yes. I did a CPU profile too just now, see below; idle.

I disabled the Atom git plugin as well as the linter, I could imagine these to run in the background, but neither helped. I’m now just disabling all plugins and will be reenabling them one by one until I figure out what is the problem. Joy.


#4

Even disabling everything didn’t help me much. I really don’t know how to investigate further. If nobody has a suggestion, I’ll just live with this for a while, getting a new machine soon and hopefully it will magically resolve itself then.