Atom freezes when opening multiple files with the same name


#1

My atom freezes and becomes unresponsive when I open multiple files with the same name (they all reside in different subdirectories inside the project). Since I am currently working on a huge ansible project, most files in my project folder are name main.yml.

My ansible project directory looks like this (with not only role1 to role2, but more like role20)

group_vars/
host_vars/
roles/
  role1/
    defaults/main.yml
    handlers/main.yml
    meta/main.yml
    tasks/main.yml
    vars/main.yml
  role2/
    defaults/main.yml
    handlers/main.yml
    ...

Here is some things I tried

  • I can open as many defaults/main.yml as there are without freeze
  • I can open one main.yml from every subdirectory inside one role without freeze
  • I cannot open two defaults/main.yml and a task/main.yml next to any of the two defaults/main.yml
  • I cannot open as many main.yml from every subdirectory inside all roles without freeze. I am unable to find a common denominator regarding the amount of main.yml I can open in this case, most of the cases it’s three but sometimes five or six.

I am using a mac, but it is reproducible on linux (fedora 22) as well. I haven’t tried windows.
I already tried safe mode, no luck there.
I removed all extensions, also no luck.

I hope all this information helps you to reproduce this bug and make it go away, it is a little bit annoying :slight_smile:


#2

I have the same error…

I have tested in Ubuntu 15.10, and it’s imposible to use. :cry:


#3

This is fixed in the v1.4.x betas.


#4

Just tested it, works like a charm. Thanks a lot!


#5

@leedohm thanks a lot!