Atom Freezes on Startup


#1

I ran into a problem today while moving my Atom editor. I was trying to move it to the workspace on my right, using the normal menu option from the title bar. It did not respond, for some reason. After I tried it again, and then a third time, Atom simply disappeared. I can still see it on my Cairo-dock but it won’t respond.

I’ve tried everything by now. Even uninstalled and installed it again, killed all processes, started with the --safe flag, restarted my computer and even removed the whole .atom/ directory. Nothing works and it is frankly perplexing; how can it still be broken after reinstalling the thing?.

When I start Atom, it appears in my Cairo-dock, but not anywhere else on my screen. I can even start multiple editors and the result is the same. I’ll attach a screenshot of it.

I’m utterly lost as what to do and I really need my Atom for my work.
Can someone help me solve this?


#2

Have you taken a look at the processes in the Debugging section of the Atom Flight Manual? Specifically the section on clearing saved state?


#3

How do you clear the saved state if the program won’t even open and freezes the entire computer to the point of shut down? This is even AFTER uninstalling and reinstalling 3 times.


#4

The program doesn’t need to open, because the state clearing happens before Atom actually tries to open. What happens when you try to clear the state?


#5

Ironically enough, I found that the program will freeze when Chromium is open. I found this through another individual. Once I closed Chromium, Arom is very responsive.


#6

That’s interesting. Does this happen with any other Electron apps, or just Atom?