Atom freezes on start


#1

My os is Gentoo 64-bit.
I run Atom from Filezilla. 1st time everything is normal, but on 2nd time half screen is black and half screen is white and it freezes. I can not close it.

Also sometimes it does not open from console.
When I open it from console and it opens normally I get:

~ $ atom --safe -f
Electron 1.6.x has reached the end of its support cycle.
Developers are encouraged to upgrade their applications to a newer series.
Read about newer series at https://electronjs.org/releases .
Read about Electron support at https://electronjs.org/docs/tutorial/support#supported-versions .
(node:4541) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): ReferenceError: atom is not defined
(node:4541) DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit

When I run it and it does not open I get


#2

Does it work if you open the first instance of Atom from FileZilla and another from the console? Does it work if you open the first instance from the console and the second from FileZilla?


#3

Thank you for reply!
It seems that the problem has to do with opening atom from within Filezilla.
Now I installed ftp-remote and it does not freeze anymore.