Atom freezes indefinitely and unusable


#1

Hi! I’ve been using atom for a couple of months now and I’m aware of the lag and freezes of the text editor every now and then.

However, when I started using is earlier this morning, it will just freeze, and will prompt me to close or keep waiting, and even if I wait for it for a long time, it doesn’t go back to its working state.

I am using the latest version of atom and I am on a windows 7 machine. I have tried using --safe and it does work there, I also tried to reinstall atom itself from scratch by deleting the .atom folder in the users, but when I restore my settings and packages using sync settings, the issue came back.


#2

This indicates that there is a community package you have installed that is causing the problem. You should try narrowing down which package is causing the problem. Some people have reported that the package-cop package has been useful in this regard.


#3

Yes I thought of that too but I haven’t installed anything heavy, just the atom power mode for fun and sync other packages from the my instance of atom from work, it works for a couple of hours, but when I triggered a live server for a practice project, it went down from there, I have tried uninstalling one by one the packages from power mode, from the packages that I have synced from work, to the live server package. Still, it freezes forever.


#4

What do you mean by “triggered a live server”? Even if something isn’t supposed to be heavy, it can be badly behaved and do bad things which could be causing your problems.


#5

I used the atom-live-server plugin for that, however, I’ve been using that package for quite some time and I don’t have any issues. Just until now, that’s the most recent action that I can recall atom worked fine.

I have found a workaround and installed the cop package, however I don’t understand how to troubleshoot using that. In addition to that just a few moments ago, I noticed that despite the endless freezing and atom not responding prompt, if I open another atom instance it will just work fine but the other window would just keep prompting to keep wait or close.


#6

My bad, I thought the workaround will last, but not. Few minutes after, atom will freeze and prompt me again.


#7

Anyone would like to help? Still, I cant fix this issue.


#8

Have you tried systematically disabling packages one at a time?


#9

Yes… Still no luck. :< The only thing that works for me is that to use it with --safe and when I reinstall it from scratch.