Atom 'freeze' on Windows 7 64bits


#1

Hi,

I started to use Atom (I had used Netbens for years) and I really love this environment.
But I have only one problem, and it drives me crazy.
When I switch between Atom ‘window’ and any other window (notepad++ for example), when I return to Atom, it stay freezed about 1 or 2 seconds.
Someone know what the cause? How can I fix this problem?

Sorry my poor english …

Best regards!


#2

Could you give the following information?

  • Which version of Atom are you using?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

The version of Atom is 1.5.3.
Yes, the problem still happens when I use ‘atom --safe’.

It’s can be caused by git index? I have read some thing about the problem is caused by auto index of git when I back to the Atom window.
Can I turn off the git index? How can I do that?

Best regards!


#4

No, you can’t really turn off the git index. It’s a key part of a lot of Atom’s features. We have some performance improvements specifically around this problem coming up in the next couple of releases.


#5

OK! I’ll wait the updates.
Can I make one suggestion? I think the index update of git should be asynchronous (if it isn’t), because I think the problem is some thing about the windows focus and the git index actualization (but I could be wrong) .
Thanks for the suporte!