Atom for people who just want a text editor?


#1

Hello everyone :slight_smile: I’m trying to use Atom as a text editor. I just want to be able to customise a little and write (as if it were Ulysses or iA writer — which I can’t afford — but better because it has things like the command palette :D).

But Atom does some things that I don’t understand how to change. Lines don’t turn into paragraphs but keep extending to the right. The editor doesn’t respond to markdown syntax by changing colour or anything. Font packages don’t actually change the editor font, nor do the settings.

What am I doing wrong? Are there any tutorials around for people who want to use Atom as a text editor only, and don’t know anything at all about code (yet)? Please help me to make Atom behave itself if you’re just using it to write papers, notes, and prose!

I’ve attached a picture (I’m only allowed one!) but I guess this is too simple a problem for pictures anyway…

Thanks very much :slight_smile:

~ Alice


#2

Lines don’t turn into paragraphs but keep extending to the right.

Toggling soft wrap should help (Editor: Toggle Soft Wrap from the command palette), see this part of the documentation for more details:

https://flight-manual.atom.io/getting-started/sections/atom-basics/#soft-wrap

The editor doesn’t respond to markdown syntax by changing colour or anything. Font packages don’t actually change the editor font, nor do the settings.

From your screenshot it looks like you haven’t saved the file yet - save it with a .md extension and you should get syntax highlighting. Or you can manually set it using Grammar Selector: Show from the command palette and then select GitHub Markdown.

Are there any tutorials around for people who want to use Atom as a text editor only, and don’t know anything at all about code (yet)?

I think the Flight Manual is helpful to go through if you haven’t yet - the first two chapters for sure:

https://flight-manual.atom.io/


#3

In order to respond to any syntax, Atom needs to have clues about which syntax it should check. In virtually every case, this is the file extension, which only exists when the file is saved.

Font packages don’t actually change the editor font, nor do the settings.

What did you add to the settings? It does work, but you may have to be more precise about how you enter the font’s name.


#4

:open_mouth: Is that Sydney Padua’s Ada Lovelace in your picture?? :smiley: :heart_eyes:!!

Thank you rsese and Damned Scholar (?) :slight_smile: I managed to do what you said. Saving the file and using Grammar Selector worked (I guess markdown doesn’t actually underline/bold anyway). So did soft wrap.

The only thing left is what I added to settings. It’s in the picture, I just wrote ‘Courier Prime’ into the field 'Font Family".
I also installed ‘fonts 3.1.0’ (the lots more fonts package) but selecting a font in the setting of that package doesn’t do anything (at least not by itself, how do you use that?).

I managed to change the font in the styles sheet, but that was luck. I don’t know what I did right.


#5

Distraction Free Packages:

iA-Writer inspired themes:


#6

For sure. I feel a lot of sympathy with the character, as I’m usually the cynical nerd shooting holes in the ideas of the more boisterous. :wink:

The only thing left is what I added to settings. It’s in the picture, I just wrote ‘Courier Prime’ into the field 'Font Family".

First, double-check that the font exists with that same name in C:/Windows/fonts. Second, test if it works to change the font to something like Arial.

I also installed ‘fonts 3.1.0’ (the lots more fonts package) but selecting a font in the setting of that package doesn’t do anything (at least not by itself, how do you use that?).

I have found it to work perfectly on install. I’m not sure why it’s not working for you, but if so we could troubleshoot that.

I managed to change the font in the styles sheet, but that was luck. I don’t know what I did right.

If you show me the style sheet, I can tell you what you did right.


#7

If you want to have untitled buffers be markdown highlighted by default, you can. Just put this in your init.coffee:

# set untitled editors (anything that opens with the plain text grammar) as markdown
atom.workspace.observeTextEditors (editor) ->
    scope = editor.getGrammar().scopeName
    if scope? and scope is 'text.plain.null-grammar'
        editor.setGrammar(atom.grammars.grammarForScopeName('source.gfm'))

You can get to your init.coffee by clicking File > Init Script…

Edit: edited code to be a bit shorter


#8

I checked that the fonts exist in my computer (I’m on a mac, but that doesn’t make a difference I guess) and they do exist. I tried typing in standard fonts like Arial and Times New Roman too, but still nothing out of the ‘Font Family’ field.
Before I try anything else in the font family field, is there something maybe in the style sheet that I’ve accidentally messed around with that takes precedence over other settings?


I’d love to get that font package working (I still haven’t managed to make it do anything) but in case that’s too much at a time, I just added pictures of my style sheet to start with. So :stuck_out_tongue_closed_eyes: What did I do right? :laughing:

Thank you so much for your help :slight_smile:


#9

Hello calebmeyer. Thanks for your reply.

I’m a little embarrassed to ask this but please understand I am starting super-small and it’s all still a bit confusing: What is an untitled buffer? (I looked online but couldn’t find anything that was clear to me).


Also I looked for File > Init Script but it’s not there — is that because I’m on a mac?

16


#10

Crap. I was braindead, I guess. Dunno what thought led me to tell you differently.

I’d love to get that font package working (I still haven’t managed to make it do anything)

If it doesn’t work and doesn’t present you with any errors, you might have to ask the package’s author at the GitHub repo if they have any ideas.

So :stuck_out_tongue_closed_eyes: What did I do right? :laughing:

Well, the first thing that jumps out at me is that your stylesheet says “Courier Prime Code”, but the config screenshot you posted says, “Courier Prime”. What happens if you put “Courier Prime Code” into the config screen?

A buffer is a data object in Atom that holds the text from a file. An untitled buffer is one that hasn’t been saved.

Also I looked for File > Init Script but it’s not there — is that because I’m on a mac?

Should be under Atom, I think. It’s also at ~/.atom/init.coffee.


#11

No need to be embarrassed.

I’m a little embarrassed I forgot that mac puts the setting for init script under Atom instead of under File (I used a mac for my first 2 years of using atom). In either case, they finally added a command to the palette (cmd + shift + p) to get to your init script (It’s a file called init.coffee that lives at ~/.atom/init.coffee).

As to the untitled buffer, that’s a holdover from me using way too much vim and emacs. In both of those editors, files are called buffers (and you don’t have tabs). In atom, when you hit cmd + n, you get a new tab which is blank, doesn’t have a title, and has the syntax set to plain text. You can type in there, but it’s probably best to hit cmd + s and save it first, since then atom can correctly set the filetype (and the syntax highlighting). The bit of code I posted above is something I use to make those not-yet-saved tabs have the syntax highlighting I want, instead of plain text.

I hope this all makes sense, please let us know if there’s anything more we can clarify.