Atom Font Weight / Anti Alias


#1

Is there an equivalent in Atom to change the font rendering? In sublime text I’ve grown accustomed to a crisp font.

This is the option in ST3
"font_options": [ “gray_antialias”]


Problem Font colors?
#2

Nevermind, solved. I added -webkit-font-smoothing: antialiased; to my stylesheet


#3

Nice one mate!
I use -webkit-font-smoothing: grayscale;
Works pretty good too depending on the font that you are usind :smile:


#4

Splendid stuff. If you’re old-school like me, and found this page after a search, you can disable anti-aliasing (font smoothing) entirely with the following entry to the .editor section of your style sheet (select menu: Atom > Open your stylesheet):

.editor {
  -webkit-font-smoothing: none;
}

And the same for the .tree-view section:

.tree-view {
  -webkit-font-smoothing: none;
}

#5

If you are on Linux, go to ~/.atom and see if there is a styles.less (I didn’t have one by default).
Or, from inside Atom editor, File > Preferences > Themes and on top of the page there is a link to your stylesheet.

edit: but fonts still look bad…I tried with:

.editor {
-webkit-font-smoothing: none/antialiased/subpixel-antialiased;
}

and nothing helped…


#6

Try auto … that works best for me.


#7

Nope, I can’t make it look as good as in (g)vim or my terminal emulator…it’s not THAT bad, but I can see the difference.


#8

Setting the CSS below and setting the font (Settings page) to Droid Sans Mono really worked for me.

.editor {
  -webkit-font-smoothing: none/antialiased/subpixel-antialiased;
}

#9

Setting the font to Droid Sans Mono and -webkit-font-smoothing to subpixel-antialiased works for me.


#10

they should set this as default settings. Amazing difference.


#11

Atom is set to subpixel antialiasing by default. Themes or packages can override it, but the built-in themes do not.


#12

Sorry to revive an old thread. I’m on Windows and this doesn’t seem to work for me.

I’ve tried all options (none/antialiased/subpixel-antialiased) but nothing happens…

atom-text-editor {
  -webkit-font-smoothing: antialiased;
}

Has something changed since?


#13

Depending on the font size and dpi of your screen, the Chromium rendering engine may not respect your font smoothing recommendation. You may want to try using atom-text-editor::shadow however. Keep in mind though that you’ll have to remove the ::shadow pseudo-selector when v1.13 comes out.


#14

Thanks @leedohm

In fact yes I’m using a hiDPI screen, that could be it.