Atom fails to open [mac]

Just as a side comment, it may be more useful to post a link to a gist with the actual file rather than a screenshot if posters are only allowed one image.

I didn’t even know gists existed until your comment so thank you. I’ll try to do that next time.

OMG this was the solution! This has been driving me nuts for weeks. Tried re-installing atom so many times. Thank you, thank you!

I ran into this just now. I looked at config.cson and this is what I see. Any idea what this means?

"*":
  "exception-reporting":
    userId: "<bunch of letters and numbers>"

It means that, when Atom sends a bug report to the developers, that’s the unique, anonymous ID that accompanies it.

In order to figure out why Atom isn’t starting, you need to provide us with the information requested by Lee Dohm above.

Ok here is what I did: rm -rf ~/.atom. Then I opened Atom via Finder. If I ls -al ~, the .atom directory has been created with the permissions “drwxr-xr-x”.

Atom version: 1.35.1
macOS Mojave 10.14.4

What happens when you start Atom with atom --safe?

That doesn’t work. Interestingly enough, I was able to use the atom CLI and open a different folder. From there, I tried opening my usual project via File > Open, and it still wouldn’t open up that project. I then did cd ~; atom . and that gave me this:

57

I clicked the left option. I still can’t open up my usual project.

I then decided to rename the folder that contains my usual project and run atom .. That opened it! However, once I rename my folder back to the original name, it won’t open.

I had a similar issue where the Icon would remain in the dock but not open any windows; running:

rm -rf ~/.atom
sudo open -a Atom

fixed it for me.

1 Like

I faced same issue. But I was able to fix it by following below steps:

Go to View > Show all tabs

This will pop up all the tabs. Then you can use Atom normally.

Thanks!
Arun53%20PM

I’m having the same problem. Tried the suggested solution and Atom crashed. Hope the extra datapoint helps :slight_smile:

I had the exact same problem!!! After seeing this ^ I fixed it by clicking view > toggle fullscreen in the menu bar.

Hey guys. I was having the same problem (very frustrating) I found a good solution to be to just search for Atom in Finder and selecting Atom from there. That appears to function everytime. Hope this helps!

I encountered a similar issue and resolved it by:

  1. Opening Activity Monitor and killing the process called “Atom”
  2. Restarting Atom
2 Likes

hi there,i recently had the same problem,i dont think its the better solution but it worked for me,just make a copy of that application and run that,i would probably say it would pop up fresh and new,and i felt that my folder which i used to run has been in my icloud,which was showing out of space so better check that and create a folder on your mac itself and then tranfer all files into this and try opening this with the atom copy

i did the same and worked for me,i would be glad if it helped you:)

This was happening for me now, and your solution worked ! Thanks!

I’ve got the same symptoms. Atom appears to be running in the dock and I can see its menu bar at the top, but none of the windows are visible. It works if I switch into full screen, but everything disappears again as soon as I leave full screen.

Immediately after posting I found the solution. The Atom window was somehow collapsed to ~1px line in the bottom left corner of my screen. I was just about able to click and drag the window back into existence!

3 Likes

I almost bought Sublime!