Atom fails to open [mac]

I had the same issue after transferring my old mac’s contents to my new laptop using the ‘migration assistant’. Atom won’t start. I deleted the ~/.atom folder and all works right now.

Had this issue today after installing Atom on a clean / previously no Atom installed Mac.

Mac is running macos 10.13, ATOM is 1.21
User account has admin privileges

There was no ~/.atom folder to delete.
Creating the ~/.atom folder caused a browser window to open, but debug fired complaining that the file ~/.atom/config.cson was missing…

I’m guessing therefore that the initialisation routine for a new installation of Atom is failing.

Any suggestions about what I can do about this?

Thanks in advance for any help!

Hah - answered my own question: permissions problem for the created ~/.atom folder. Could someone advise what should they be? (set to 777 to get this fixed, but am sure this is not the correct setting…).

If there’s a permission issue, then that usually means that the file isn’t owned by you (744 is “correct”, from a security perspective). You should chown it to yourself.

Thanks - that did the trick. :slight_smile:

Hi there. Atom is opening for me — I see it open in the dock, as well as in the menu bar. In the dock, if I click and hold on the icon, I can also see that Atom has/thinks it has several windows open.

However, the windows are nowhere to be found!

I have tried deleting the .atom folder. I have also tried deleting the .atom folder, then uninstalling and reinstalling the app. If I view all open windows (via f3 or similar), the Atom windows are not present.

I currently have version 1.22.0 installed on mac OS 10.12.6. I am using a macbook pro with a second monitor.

1 Like

Was this issue solved?
I just bought a Mac (10.13.2)
I installed Atom successfully, and it was working, but then I closed it out and it stopped working. I did a complete uninstall and re install and still not working.
I cannot see the Atom menu, but I can see the atom icon in the doc.

What ultimately solved this problem for me after un- and reinstalling and still being unable to open a new Atom window was to start atom from the command line:

atom --new-window

Hey there, I have a Macbook Air iOS 10.10.5 and am installing atom 1.28 from https://atom.io. However after few attempts and restarting, I still cannot open atom, the same error message asking to reinstall Atom / reinstall the newest version came up, and the error code repeated is shown as below. Any tips will be sincerely appreciated!! :slight_smile: Many thanks!!

“Dyld Error Message:
Symbol not found: _CIDetectorTypeText
Referenced from: /Applications/Atom.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework
Expected in: /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
in /Applications/Atom.app/Contents/MacOS/…/Frameworks/Electron Framework.framework/Electron Framework”

Hey there, I have a Macbook Air iOS 10.10.5 and am installing atom 1.28 from https://atom.io. However after few attempts and restarting, I still cannot open atom, the same error message asking to reinstall Atom / reinstall the newest version came up, and the error code repeated is shown as below. Any tips will be sincerely appreciated!! :slight_smile: Many thanks!!

Since you’re on Atom 1.28 and based on your macOS version and the error message, I think you’re hitting the issue referenced in:

We suggest installing 1.27.2 and turning off auto-updating for now /cc Atom won't start all of a sudden.

I just downloaded the latest version and this is what i get when i run it on my mac

dns.js:246
this._handle = new ChannelWrap();
^

Error: EFILE
at new Resolver (dns.js:246:20)
at dns.js:377:25
at dns.js:431:3
at NativeModule.compile (bootstrap_node.js:606:7)
at NativeModule.require (bootstrap_node.js:550:18)
at net.js:45:13
at net.js:1730:3
at NativeModule.compile (bootstrap_node.js:606:7)
at NativeModule.require (bootstrap_node.js:550:18)
at internal/child_process.js:6:13
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.
Deleting expired sessions…none found.

If you download and install atom,
then you need to go ‘Install Shell Commands’ in atom menu manually.

What worked for me was going to the applications folder, right clicking, show package contents. Once there, i navigated to the atom executable in the MacOs folder and double clicked. This started atom in a terminal window with a print out log of the initialization. I was able to see that there was an indentation error in my config file.

I think navigating in your finder is more helpful, because you can open the executable manually in your terminal by right clicking on it.

But for those who like copy paste solutions:

$ /Applications/atom.app/Contents/MacOS/Atom

Config file that was the culprit for me was was located here:

/Users/<username>/.atom/

What exactly did you do once you found the indentation error? This is what I get but I don’t know what to do about it. Does anyone have Xcode installed on your mac as well because Atom stops working whenever I install Xcode. I cannot find .atom folder anywhere either.

Based off your screen shot, it appears that atom is starting fine, or whatever your issue is that it’s not related to the config file.

And to answer your question about the indentation error-- After i found it, i fixed it by editing the file in another editor like VS code or TextEdit.

I’m having the same problem.

  1. Running Mac OS Mojave 10.14.3
  2. Running Atom 1.34
    I’ve had atom for a while now and never encountered problems. I configured atom for running Python files last night using this tutorial: https://www.youtube.com/watch?v=KOB_gUZ0rM4
    I installed atom runner and added this to the config.cson file.
    “runner”:
    “scopes”:
    “python”: “python3”
    Everything worked fine until I started it up today. No windows open only 1 option in the menu for quitting. This is what the atom executable shows:

    Any help would be much appreciated!

Rather than copying and pasting a tiny bit onto the forum, you should post a screenshot of your entire config.cson file so that we can tell you if there are any syntax errors.

I tried to do that but it said I could only post 1 picture. Here it is.

Is there something in there about linter-ui-default?

Not anymore I got impatient and reset the factory defaults and it works now. I hadn’t installed very many packages so it wasn’t a big deal resetting it. I configured it for Python a different way and everything seems to be working fine now. Thanks for the help, though!