Atom fails to open [mac]


#1

Atom fails to reopen, the menu-bar shows up, but the app fails to open. I’ve tried all of the menu items, opening in dev mode, to no avail This has happened twice now on my mac. The first time I completely removed everything .atom related which was a pain to track down and remove. This time I had atom open, attempted to open a new atom window and open a different directory. Atom did not open the directory, so I closed the 2nd instance. I then closed the first instance and tried to re-open Atom, and I’m back at only the menu bar showing. I have a feeling I will need to completely remove and reinstall again…

Anyone else experiencing this issue?


#2

I haven’t seen any of this, no. Could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3
  1. 0.182.0
  2. OSX 10.9.5
  3. Yep

#4

If the menu-bar shows up, the app is open to some extent. Did you try deleting just the ~/.atom/storage directory?


#5

Getting same probelm, got a mac the other day install Atom and is doing it see video: https://www.dropbox.com/s/8sig7stiusrkrg7/Atom-Bug.mov?dl=0

Running on 10.11.2 El Capitan, Atom 1.4.0 default packages.

Deleleted ~/.Atom/storage

Still have problem. Tried deleting Atom completely and reinstalling still go problem.


#6

This is fixed in v1.5.0-beta0:

You can always open a new window with Cmd+Shift+N.

BTW, thank you for the video … that helps a TON.


#7

Has this ever been resolved? I haven’t been able to open atom on either of my macs.

Atom 1.6.0

System Information: Model: MacBook Pro (Retina, 13-inch, Early 2015) • CPU: Intel Core i5-5287U (4 Threads, 2 Cores) @ 2.90 GHz • Memory: 16.00 GB • Uptime: 7 days • Disk Space: 499.06 GB • Graphics: Intel Iris Graphics 6100 • Screen Resolution: 1920 x 1080 • OS: OS X El Capitan (Version 10.11.4, Build 15E65)


#8

@fourq As stated above, the specific issue reported here was fixed in v1.5.0-beta0.

If you’re running into a problem launching Atom, please give us a bit more information like steps to reproduce the behavior, how you installed Atom, etc.


#9

@leedohm

Sure, I’ve tried downloading it from https://atom.io/download/mac, and brew cask. After it’s installed I run the application (tried from the terminal, and from the Atom.app itself. The atom menu icon always shows in the dock, but never opens. I tried right-clicking it and showing all windows, double clicking it, opening from iterm with sudo, and without sudo.

video: https://fourq-dropshare.s3-us-west-2.amazonaws.com/jgjSVYu7wz


#10
  • When you installed it from the website, to what directory did you copy the Atom.app?
  • Is your account an Administrator? Or regular user?
  • Did you completely delete the ~/.atom directory after you tried launching it with sudo?

#11

/Applications
Administrator
yes

So after grepping the system for “atom” I found that I had a ~/Applications dir that looks like it was created by Windows Parallels. I’m not sure why that was the dir that it ended up being installed into. The strangest part is that /Library/Applications/atom was actually a symlink to ~/Applications/atom executable. After deleting that dir, and uninstalling atom again, I was able to install from the website download.

I would love to blame it on Parallels, but it’s all a little strange considering that my other mbp had the same issue, but doesn’t have Parallels on it.

Either way, i’m up and running, so thank you!

If you’d like me to test anything out to see if we can’t nail down the exact issue, just let me know.


#12

I’ve encountered the same exact issue as threadstarter, Atom icon appears in dock and the menubar at the top right beside the apple icon the Atom option appears but the dropdown only has a quit option when i clicked on it. Seems like the app is half opened or something.

MacBook Pro OS X El Capitan 10.11.6
downloaded the latest mac version from https://atom.io/ , moved zip file to Applications and unzipped from Finder.

I’ve tried running the following commands in terminal to uninstall and install again but the problem persists.
Any idea what can i do to fix it ?

rm -rf ~/.atom
rm -rf /usr/local/bin/atom
rm -rf /usr/local/bin/apm
rm -rf /Applications/Atom.app
rm -rf ~/Library/Preferences/com.github.atom.plist
rm -rf ~/Library/Application Support/com.github.atom.ShipIt
rm -rf ~/Library/Application Support/Atom
rm -rf ~/Library/Saved Application State/com.github.atom.savedState
rm -rf ~/Library/Caches/com.github.atom
rm -rf ~/Library/Caches/Atom

#13

@ashtonnnn Is your user account an Administrator? Can you check the permissions on and in your ~/.atom directory?


#14

@leedohm Yes I am an administrator.

is it on this directory ? I tried cd ~/.atom and it goes there.

/Users/MyUserId/

this folder doesn’t seem to exist , although i reinstalled Atom.

/Users/MyUserId/.atom: No such file or directory


#15

If you’ve installed Atom and you’re trying to launch it, it should create that directory for you first thing. The permissions in your home directory /Users/MyUserId might be messed up in such a way that it can’t create it. That would cause this problem.


#16

Ah that was the issue ! … apparently my user account permission for that folder was stucked in fetching status, a bug highlighted here : https://discussions.apple.com/thread/3198307?start=0&tstart=0 .

I solved it by creating adding new permission for my account for that particular folder.

Thanks so much @leedohm !


#17

I ran into the start up issue as well (no window, just a menu bar and icon in the dock). After quitting Atom, I deleted an old .atom directory inside my home directory and Atom now starts normally.


#18

Some more details here for the same issue I’m running Atom 1.10.2 on Mac OS 10.11.6, so here is the issue :
When launching Atom an empty window open, and everything is fine.
If you close that window, you can’t open file or directories : the pop up won’t appear.
At that point the trick is to click the atom in the dock and a blank window will open again.

So the issue is somehow still there


#19

Try searching out some virtually undetectable lines on your desktop. I was having the same issue and discovered that the windows were in fact open, but had been shrunken to thin lines. When I dragged over them I was able to get the editor window to expand.


#20

Thought they were shooting stars at first :dizzy::astonished: