Atom fails to open files when opened from desktop [Manjaro Xfce4]


#1

I have installed Atom on my latptop, running Manjaro 16.06 with Xfce4 desktop.

When I open a file, say a .txt file from the desktop interface by clicking on it and doing Open with -> Atom, Atom opens, but the file’s contents are gone.

All I get is an Atom window, with the file displayed with “%” where the spaces are. So if I open “two birds.txt” from the file manager window, Atom opens up with

“two%birds.txt” - “file:/home/user/documents/two%birds.txt”

in the title bar. And there’s nothing in the text body.

However, if I open Atom, and then open the file from the file menu, it opens just fine. What’s going on?


Atom fails to open .txt files when opened from Xfce desktop
#2

What happens if you open Atom from the command line with atom "two birds.txt"?


#3

Good question. It does the same as when opening the file from the desktop. Atom opens up with the filename, but the contents of the file appear empty. Only if I open from the application’s file menu to the contents appear.

I think there is something wrong if the filename is being displayed with the ‘%’. Why is Atom showing files, even when opened from it’s own file menu as

two%birds.txt

in the title bar? Shouldn’t it just read

two birds.txt

the way that every other application works? For context, Sublime Text works just fine on this machine.


#4

That’s confusing. It has to be something with your computer, but it doesn’t seem to be Xfce. I have a Manjaro i3 box right here and it has never had a problem.


#5

And what about a file named two_birds.txt? Does that work correctly?


#6

Nope. Same result.

So the problem is not with the space in the filename, although the fact that Atom is displaying that % sign in lieu of the empty ’ ’ seems to me to be abnormal.

Atom is based on Chrome. I can open this text file with Chromium from the desktop context menu, right click -> Open With. I should be able to do it with Atom.

I installed this from the Arch User Repository. I have tried removing it and reinstalling. Should I instead try installing from the downloadable package on the Atom website?


#7

Which AUR package did you install, exactly?


#8

pamac and yaourt report:

atom-editor 1.8.0-1

I installed it via Pamac front end. I’m pretty sure it’s this package:

https://aur.archlinux.org/packages/atom-editor/


#9

Can anyone help here?


#10

I’m still clueless. Atom has worked for me on Manjaro for months (I currently have the atom-editor-bin 1.13.0 package installed). Have you tried building it from source? I’ve done that and it worked fine.

None of the official Linux packages are for Arch, so the options are to use the AUR, download one of the tarballs and build it, or clone the repo and build that. I’ve succeeded with all of the above.