Atom Fails to Launch OS X 10.9.2


#1

Hi Everyone -

I’m having trouble getting Atom to launch on my Mac. I have OS X 10.9.2, and Atom 0.80.0 (just re-downloaded from the front page).

When I launch Atom, I get a white screen with a console visible

TypeError: Object #<Object> has no method 'register'
    at window.onload (file:///Applications/Atom.app/Contents/Resources/app/statis/index.js:18:30)

There is another error when I attempt to click anything in the lone Atom toolbar menu as well:

TypeError: Object #<Object> has no method 'focusedWindow'
   at submenu.click (/Applications/Atom.app/Contents/Resources/app/src/browser/application-menu.js:139:37)
   at MenuItem.click (/Applications/Atom.app/Contents/Resources/atom/browser/api/lib/menu-item.js:38:18)
   at delegate.executeCommand( /Applications/Atom.app/Contents/Resources/atom/browser/api/lib/menu.js:78:31)

Any ideas on what I can do to get Atom running?


#2

Did you try the suggestions on this other thread?


#3

Yes. My app launches, and I get a webkit window with a visible webkit inspector, and an error in the console. Check out the screenshot here.
imgur(dot)com/N0aBffN

Sorry for the unclickable url, But it says new users cant put images in posts


#4

bump, i can’t be the only one with this problem.


#5

expand the error so we can see the full exception please


#6

Here is the expanded error. Theres not much else to it.

imgur(dot)com/b3EGlm8


#7

Have you tried uninstalling and re-installing atom? like a new download and everything? maybe give that a shot.


#8

I have tried that multiple times on multiple occasions, even on different wifi to make sure its not corrupting anything. I’m at a complete loss.