Atom Errors With "Unable to get local issuer certificate"


#1

I am unable to install packages.

I tried the strict-ssl=false from [this page|https://flight-manual.atom.io/getting-started/sections/installing-atom/#proxy-and-firewall-settings] but I still can’t search for packages.

I am on a corporate network with Websense/Forcepoint protection. Forcepoint replaces SSL certificates for outbound HTTPS so that you always see the FP cert, not the original website’s cert. For Git, I had a similar issue and I had to add the Forcepoint cert to the bundle used by the app. Firefox also had an issue until I added the cert to it.

What do?


#2

Same here, even with strict-ssl=false set!


#3

Same. Even tried setting https-proxy=<host:port> and no change.


#4

This only fails using the Atom UI. On windows do the following to install, say atom-beautify:

Start > Run > cmd

cd %APPDATA%…\Local\atom\

find your latest app- folder, such as app-1.27.2

cd .\app-1.27.2\resource\app\apm\bin\

to be safe, add to your current cmd session PATH

set PATH=.;%PATH%
.\apm.cmd install atom-beautify

TASK Manager will report a “node.exe” process pounding away on the CPU, just wait for it to finish. command-line will report “done”, then exit the cmd window.

exit


#5

This is still a bug. Where is the Atom GUI pulling its .atomrc settings from, if not ~/.atom/.apmrc?
I reported this bug directly in the Atom Github issues and the devs closed it promptly without comment. Why?


#6

If you’re talking about this issue, it was moved to the settings package repo (as the bot comment says)