Atom editor width


#1

I’m new to Atom, but it seems to be the most worthy and accurate mmd editor. I find a weirdness that’s particularly vexing when making wide tables.

On an imac, I find that when I bring up a file, old or new, the line width is full window worth for an instant and then immediately shrinks to a width that I don’t believe I set. I set preferred line length to be 500 in order to be sure that’s not it.

When I toggle soft wrap off, this windowing happens and a horizontal scroll bar appears and I must use that to see a formatted table. I typically use markdown writer, but it’s not dependent on that.

I must be missing something but I can’t figure it out. I’m exclusively on new imacs and am using Atom 1.23.3x64 and markdown writer 2.7,3, which I don’t blame.

Any suggestions would be welcome.

thanks


#2

I am having difficulty following your explanation - sorry.

Somehow I think it is a line ending issue. Do you know what character(s) make up your line endings? Bottom right has a indicator for that (LF / CRLF).

Could you post a picture perhaps?


#3

Sorry. Here are two screen shots. One has soft wrap on and you can see that the table is messed up as you’d expect. I don’t know what is governing the width of the editor window here. I’ve intentionally shown a lot of the un-used real estate.

The second figure (next post) is with soft wrap off and I’ve intentionally scooted the window contents so that you can see the horizontal scroll bar and the cut-off of content at both edges of this “artificial” window width.

Does that help? I hope the images are properly uploaded…I could not upload 2 images in one post, so the second image is in the next reply.

thanks


#4

here is that second image with that explanatory paragraph repeated:

The second figure (next post) is with soft wrap off and I’ve intentionally scooted the window contents so that you can see the horizontal scroll bar and the cut-off of content at both edges of this “artificial” window width.


#5

What does this look like?
(bottom right)
image

Please also activate the invisible markers:

…and repeat your screen captures (thank you)

<shift ends>


#6

Sure. Thanks for sticking with me. The lower right hand image is attached. screenshot_2993


#7

and the settings for the editor is attached


#8

Hello.

Thank you for the all the pictures and the descriptions that went with those.
It is with fresh eyes that I evaluated all that you tried to tell me.
I am sorry, I was sending you down the wrong path.

From all the pictures I noticed that the Markdown text is ‘centred’. I use typewriter and/or zen for that type of behaviour. Are you aware which package is doing that for you?

By messing around with the settings in typewriter and/or zen, I could get what you describe. These also overrides whatever I think I am adjusting on Atom’s system settings when it comes to text wrapping. What makes things a little worse is that if I disabled these packages, the influence remained until restarting Atom.

Restarting can be done with Ctrl + Shift + F5.

A quick way to determine if a package is at fault, is to start Atom from a terminal as atom --safe. Then evaluate what type of behaviour you have.

I recommend you have a look at the “whatever-makes-text-stay-centred” package. You’d be able to adjust things there to get the behaviour you would want, I hope.

What are your thoughts?
- Dan


#9

Hi
Thanks for the reply. I"ll try it. I did try to start Atom in safe mode before posting and it behaved as I would have expected, but of course no packages. I kind of hoped that would clean out whatever was making it happen, but it didn’t when I went back to a normal start.

How can you tell that it’s centered?

thanks


#10

I think I figured it out. Your Zen comment made me remember…I use Markdown Preview Enhanced…and it has a Zen selection, which I interpreted to mean that I could invoke it if I wanted to. But it seems to mean: Zen, all the time. When I unchecked it then I got my screen and window back.

Thanks for your help!