Atom editor started displaying empty area highlighted

Notice on the right side of the screenshot, it’s been filled with shaded or highlighted empty area,
This started happening like two days ago or so,
Not quite sure if it was the new update that caused it but I do have the auto-update on.
When I “Select All” in view, the highlighted empty spaces would actually disappear making it look like nothing has been highlighted(selected) ?! very strange.
Selecting all and copy/paste of the page does work so it’s just visually not highlighting the whole page.

Tried changing to a different theme, --clear-window-state but no avail.

Any clue as to why it shows like this all of sudden?

It’s not actually filled with that lighter blob, it’s the darker stuff to the left that doesn’t fill the whole window.

The issue itself is that, somehow, the default background colour has changed from the background colour of the rendered text line tiles. I personally experience this too, but less pronounced.

I can’t find where I saw people discuss it recently, but I think I have at some point. I’ll update with a link if I ever come across it (and remember :slight_smile: )

I wasn’t really sure exactly when it started doing this.
Possibly since yesterday or maybe a day before yesterday but anyhow
I looked up into the git files and looks like there was a file update yesterday.

atom/spec/text-editor-spec.js – a day ago

–> Reset goal column on all cursor changes

“Previously, pressing the home key (move-to-first-character-of-line)
while on an empty line wouldn’t clear the goal column. This is because
it was only cleared on cursor change and that didn’t result in a
change. With this commit, it’s always cleared. Operations that want
to preserve the goal column can reset it afterwards.”

Basically when I click on any line, yeah about 4 lines of highlighted area go away or gets cleared.

I don’t know if the above mentioned has to do with the issue I’m having,
but I’m on a Ubuntu 16.04 64bit.

Any luck fixing this issue? I’m having the same problem!

Set Settings -> Core -> Color Profile to Use sRGB color profile


OMG!! Thank you so much!! Spent way too many hours digging around different settings!