Atom Editor no padding/margin/gutter


#1

Hello, I’ve tried
atom-text-editor { padding: none; }
and
atom-workspace { padding: 0px; }

but the outlined margin still there. Is there any way to dismiss the gutter/margin/padding?

Thanks.


#2

It’s hard to tell what you’re actually trying to hide, to me it looks like the framing of a laptop screen :slight_smile:

Anyway, it’s always best to use of the Developer Tool’s inspector tool to identify the elements you’re trying to manipulate!


#3

Sorry for not being specific, what I meant to get rid of is the white gap. I was able to widen the gap by adding more padding e.g. 10px.


#4

There is information on how to find out what element or class to style in the Atom Flight Manual. You may want to check that out.


#5

Actually in both sides.

Struggling to find the corresponding element, doubt that it’s default setting.


#6

My Element setting have the margin set to 0 and it does look less padded to me


#7

Have you tried using the Element picker?

Click that button and then you can click directly on the element that you want to select it in the Elements view.


#8

I was able to remove the gap by:
atom-panel-container.left { min-width: 0px; width: 0px; }
however, the file tree pane won’t show when toggle it on and off. Any suggestion?


#9

If you change the style to:

atom-panel-container.left {
  min-width: 0px;
}

then everything should work properly.


#10

That does slimmed down the gap a little bit, though there’s still 4px gap with nuclide. If I set those 4px to 0px, the file tree pane will not show.