Atom doesn't work on Ubuntu on Wayland


#1

Hi, I’m using Ubuntu on Wayland because of other apps, which doesn’t work on ubuntu, But when i start atom (even form menu or from terminal) the system suspends, and i have to log in again. In normal Ubuntu it works perfectly. Do you know the solution? I tried to reinstall atom, and instaled libgconf-2-4 as was suggested, but did not work.


I’m using:
Ubuntu 18.04.1 LTS
Gnome 3.28.2


#2

OK, this may not be much help because I don’t work with Ubuntu, but some of the problems I’ve seen with Wayland are due to permission problems, which may show up in system logs. Atom is built on Chrome – does Chrome work on Wayland? Have you gone through the troubleshooting section in the docs and tried running atom --safe?


#3

Yes, chrome works even better than on Ubuntu (some touchpad issues), and after trying atom - - safe, the same thing happens (I’m being logged out). Unfortunately


#4

What version of Atom are you using (atom -v)? And how did you install Atom?

I just tried Atom 1.28.0 on Ubuntu 18.04 with Wayland and Atom started ok.


#5

Now I have version 1.29.0. And I tried both instalation from terminal and from ubuntu software.


#6

From the terminal, which installation method did you use (i.e. the .deb or apt-get)?