Atom doesn't open! (solved)


#1

Hello,

I tried to open Atom, like I do every day. But for some reason, Atom doesn’t open. I get this message from my computer :

I really don’t want to reinstall it because of all the plugins I have installed (it would be a pain to get them back). I restarted my computer but the bug is still there.

Is that a frequent problem ? How can I solve it ? Thank you.


I have solved my problem, thanks anyway !


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?
  • How did you install Atom?

#3

Thanks for the answer. I am using Atom v1.5.4. My version of OS X is 10.11.3.

I’m not sure what you mean by “completely exiting Atom”, but anyway, the application is closed (i can’t launch it). I tried to use atom --safe but the error still occurred.

Finally, I installed Atom from the normal website atom.io (I didn’t know there were other ways to install Atom).

EDIT : I did search for Atom in the activity monitor by search for “Atom” but there were no process

EDIT #2 : I checked the debuging document but I couldn’t do most of what it said I should do since I can’t open Atom at all. :frowning:
I just thought of something : the last time Atom was open, I did the update to the latest version (the one sepcified above). Theproblem probably comes from here.


#4

Some people close the window, but not the application. For the instructions to work well, you should start from not having Atom loaded at all. (It also doubles as a “close the program and restart” step :grinning:)

Where do you have Atom installed on your system?


#5

Ok, well it’s the application that is (completely) closed then. Atom is installed in my Applications folder : /Applications/Atom.app.

EDIT : If I delete the application (Atom.app), not uninstall it, then download it again and put it back to my Applications folder, will me packages be saved or will I have to install them again ?


My problem is now solved ! I have reinstalled the app (it didn’t delete all my settings and packages :pray:) and now it works well. I hope it will stay like that. Thank you for your help.