Atom doesn't install the latest version of my package


#1

I’m maintaner of AngularJS-Atom package.
Recently many users reported my package use deprecated API, I’ve already updated.

In “install Packages” section of Atom, it show the lastest version of AngularJS-Atom.(0.2.0 is lastest version now)
But Atom show 0.1.0 instead 0.2.0 after a while. And it warnd “Version 0.1.0 is not the latest version available for this package, but it’s the latest that is compatible with your version of Atom.”

I don’t know why. I missed something?

`package.json’ is like below.

engines": {
    "atom": ">=0.174.0, <2.0.0"
  },

Could somebody help me?


#2

Sorry, Somebody already fixed my mistake.
It solved.


#3

That make me think that there’s no control over the validity of the engine version field in package.json. Maybe this should be handled by apm before publishing a new version.


#4

So, it appears the problem had been fixed the 10th February of this year, but your version 0.2.0 was published 2 day before so you didn’t benefit of that change.


#5

Thank you for information.
I thought that’s weired when users report they can’t update it.


#6

Hello guys, Im new right now in Atom and I have this message also, the same problem,
can someone try to help me ? thank you…


#7


#8

Pigments has a version that is designed to work with a beta version of Atom because of the Shadow DOM removal that we’re working on. The version that you have is the latest version for the stable version of Atom.