Atom does not show up


#1

I cannot figure out why Atom has stopped showing on my new created account on Centos 7. I tried everything. I removed the old version, downloaded again the new one and installed using yum , removed ~/.atom, ~/.atom.bak, ~/.config/Atom and tried to run again but it still does not show up. I can see atom residue in the list of processes, though.

When I look inside ~/.atom, I can see nohup.out is one the only existing fikes which shows the following log:

EPERM: operation not permitted, unlink '/tmp/atom-doRjhBG-nhNX.sock'

Error: EPERM: operation not permitted, unlink ‘/tmp/atom-doRjhBG-nhNX.sock’
at Proxy.fs.unlinkSync (fs.js:1091:18)
at AtomApplication.deleteSocketFile (/usr/share/atom/resources/app.asar/src/main-process/atom-application.js:351:12)
at AtomApplication.listenForArgumentsFromNewProcess (/usr/share/atom/resources/app.asar/src/main-process/atom-application.js:335:10)
at AtomApplication.initialize (/usr/share/atom/resources/app.asar/src/main-process/atom-application.js:155:10)
at Socket.client.on (/usr/share/atom/resources/app.asar/src/main-process/atom-application.js:84:59)
at emitOne (events.js:96:13)
at Socket.emit (events.js:191:7)
at emitErrorNT (net.js:1283:8)
at _combinedTickCallback (internal/process/next_tick.js:80:11)
at process._tickCallback (internal/process/next_tick.js:104:9)


#2

Funny enough, this has been hapening on a new created account. I created another one “test” and run Atom without any problems. I suimply decided to re-create my account again with little effort and so far everything is ok.