Atom does not open

Installed a new Atom 1.40.1, it does not open. Reinstalled, also does not work. I downloaded the zip archive, it also does not open. Win 10 pro 64bit 1903v.

Have you tried starting in safe mode?

I did, it still doesn’t open. Visible in task manager processes.

Can you give more detail on what you did? Please be specific; especially on things like which ZIP you used.

Do you know of these instructions? -
https://flight-manual.atom.io/getting-started/sections/installing-atom/#portable-mode
Where the .atom folder is placed, is of importance.

TIP: to make a .atom folder, name it first as .atom. (x2 dots) which automatically changes to .atom (x1 dot).

I downloaded atom-x64-windows.zip, unpacked it to disk D (not the system one), created the .atom folder near the executable file, launched atom.exe, the program did not open but was visible in the task manager processes.

How did you launch it?
From the command line or from the Windows Explorer?

Just double click in explorer

Give me clarity on this part too, please.

…perhaps on 2nd thought we do something else.
image

Ignore the BAT file in the picture.
Notice the folder structure.

You can create a sub folder from your D:\, mine is called AtomAlpha.
Inside you unzip the ZIP file. Place the files in a folder, mine is called main.
You will see the executable is D:\AtomAlpha\main\atom-nightly.exe
That is 2 folder depth.
Note next where the empty .atom folder is placed.

Show me a screen capture of the structure you come up when following these instructions.

Looks good.
Best to make sure there is no processes of Atom running.
Log out and log in, into your Windows user if you want to make 100% sure.
So… what happens when double-clicking atom.exe?

You can call the AtomAlpha whatever you want …
Provided there is no {spaces}, ASCII characters (guess) and legal according to Windows’ naming conversions.

Works. Thank you very much. For one I ask how do you like JetBrains PhpStorm? Installed it until Atom worked, maybe stay on it?

Nice!


Consider now the following steps:

  1. Delete the contents and folder %localappdata%\atom\

  2. Delete the contents and folder %homepath%/.atom


The main problem that you faced (in my opinion) is that components in the Atom app does not handle non-ascii characters that well. You use Russian-type alphabet - right?

Disadvantage with what you have now - the Atom app does not automatically update. I do not find this as a problem as I know when I make an update. I know when something does not work anymore because of it.


I do not know. But that app has been purposely built for the task. There is good possibility that beginners will feel more at home with it. Its like a swiss-army-knife vs steak-knife when eating a steak. But have a beer with the food and you wish you had the swiss-army-knife.