Atom does not open files Ubuntu 18.04 Hugo

Hi,

New-ish to Atom, but competent dev.
Ubuntu 18.04
Hugo latest
Atom works fine for a while, and then will suddenly refuse to open any file.
I have been through the topics here, and seen a few similar issues, but no solutions have worked for me eg deleting ~/.atom.

Any suggestions welcome.

TFL.

Be aware that there are other Atom files in different locations.
For example ~/.config/Atom

I sometimes temporarily disable that folder (by just changing its name) when testing but it springs up again with default settings. Easy to restore.

And if you use markdown-preview-enhanced package it uses ~/.mume

A package I use to quickly enable/disable packages is package-list.

Then you have developer tools to look for errors. Lots of avenues to chase. Just gradually unwind to a stable state

Hey thanks,
I went through a few of the debug commands.
This one seemed to be the clincher, although as I say I had previously deleted that dir a few times.
mv ~/.atom ~/.atom-backup
Anyway, up and running again at the mo.
Cheers for your help
Have a great weekend.
Kai.

I decided to install Hugo just to play with it. Also installed HomeBrew. The Hugo commands can all be run through process-palette without need for further packages.

Thanks, d_l,
I appreciate your input.
Very useful.
I have solved the initial prob, for now, and learned a couple of things.
All good.
Muchas gracias.

1 Like