Atom does not allow me to have more than 12 tabs open


When I have 12 files (tabs) open, and want to open another tab, Atom closes one of the open ones, i.e. I can not see more than 12 tabs. It seems that there is a limit on the number of opened tabs.

I then installed the “multirow-tabs” package, hoping that this would allow me a larger number of tabs, but this also shows at most 12 tabs only, though nicely arranged in two rows.

I had expected some setting either in the “tabs” or in the “multirow-tabs” package, which would limit the maximum number of open tabs, although I don’t quite understand why such a limit is imposed in the first place, but anyway, there doesn’t seem to be such a setting.

Any help appreciated…


Have you tried scrolling the tab bar?

I’ve got 19 open right now.


Do you have some package installed that automatically closes them? For example the zentabs package does this. The easiest way to test if it’s caused by a community package is to start Atom in safe mode atom --safe.


How can I scroll the tab bar? It doesn’t have a scroll button.

I don’t think that scrolling is the solution, because with multirow-tabs, the first row is filled completely and the second row is filled half, so there would be enough space to create tab number 13.


I use two fingers on a Mac, but holding shift with a mouse wheel is also common for horizontal scroll.

But yeah, if you’re tabs are already on multiple lines, it may be a community package that’s causing it.


I don’t have zentabs or something like this, so I was pretty convinced that it can’t be an effect from another package. Well, I was wrong: Restarting in safe mode showed that I then indeed don’t have any limit for the number of tabs.

After some research, I found that the culprit was the package close-other-tabs. According to the documentation, this package does

…close inactive tabs using option-command-w

It seems that this package does more then this: It obviously closes inactive tabs without being told! After disabling this package, everything works fine now.


The zentabs package can be configured to manual mode and close inactive tabs (The least recent) with a command instead of automatically. I have it configured that way and it’s great. You may want to try that out as a replacement for close-other-tabs!