Atom displaying weird characters [mac]


#1

Hi. Atom is displaying some weird characters for newlines, as well for accented characters like áíúéó

I don’t think it’s an atom problem it itself, but how it interacts with something else

Here’s what I get in the text box against what I see in the console.

  • As you can see it’s not just in the text window but in the interface.
  • I’ve checked the encoding in the settings and it’s UTF-8, other
    encodings don’t work either
  • I’m sure it has something to do with
    language settings somewhere else because in the source, for the same
    text box, I can see the characters I’ve written

Thanks to anyone who can provide help


#2

This sounds almost identical to this Issue:

It appears in the above issue that the font has a strange glyph for  . Maybe @braver can help out here? They’ve been pretty helpful with other font issues in the past.


#3

@leedohm Yes, it seems almost the same. I’ll try some other fonts in the meantime. But I agree this maybe a chrome problem itself. Looking into it.

EDIT: I can confirm that using a different font I don’t see the same behavior. My doubt now is: FontFamily parameter was empty, so, what font was it loading by default?


#4

Hard to say what’s causing this. I’m not a font author myself, so I don’t really know all the ways that fonts can go wrong. I’m assuming it’s simply like @leedohm says, in that font some character is mapped to the non-breaking space by accident.

You can find out the name of the font from the developer tools (although for some fonts it will unhelpfully report “OTS derived font”):


#5

If you know what font reproduces the problem, you can look at the Font Book application on OS X. Unicode glyph U+00A0 is the one for  .

@simurai Do you know which font is chosen when none is specified?


#6

Ok. I left in blank the Font Family from the preferences again and reproduced the error. The font was Inconsolata
So I went to Font Book to check the font, and while I’m not sure how to find an specific Unicode Glyph, I found a Font Validation utility.

I ran Font Validation for Inconsolata and got “1 serious error” so I removed the font. Why was there an error I’, not sure.

I went back to Atom, FontFamily setting empty, and now   is rendering properly. And the Rendered Font in developer tools is still Inconsolata.

So, it wasn’t the Chrome engine, and as I suspected nothing to do with Atom itself. It’s still a weird error to me. I don’t know where it came.

Thanks @braver @leedohm


#7

For future reference:

  1. Open Font Book
  2. Select the font you want to view
  3. Select the menu View > Repetoire or press ⌘2 to show all glyphs in the font
  4. You can then hover over characters to see more info about them:


#8

Good to know. Thanks, @leedohm


#9

Yes, the default text editor font used in Atom is Inconsolata.

I tried to reproduce this by downloading Inconsolata from Google fonts: http://www.google.com/fonts/specimen/Inconsolata but in my case, everthing is fine. @Darkade maybe you had some “older” version installed and could try to re-install the Google font version?

This could also be related to the “vertical alignment” issue we had recently. That bug seems already fixed. So maybe in Chrome 41 this   issue would be fixed as well?


#10

I think it was the the font was somehow corrupted. As I was saying, I had two versions of the font installed and once I deleted the one with errors Atom continued to use inconsolata without any problem.

Why was it corrupted in the first place I don’t know. When I deleted the corrupted font it went away, not even to the bin, otherwise I’d post it for you to try to reproduce. :disappointed_relieved: