Atom creates continueously increasing # of Bash-processes?


#1

I cleared my Linux-PC of any and all atom-references.
Re-installed the latest, stable atom from .deb

When I start atom, it (?) starts to create a bash-process, seemingly every second, quickly eating up all 12Gb of RAM. I need to restart my PC to get rid of it.

Upon inspection: /bin/bash -ilc command env

LinuxMint 18.1 Serena x86_64
Cinnamon 3.2.7
Kernel 4.8.0-34


#2

Can you replicate the problem in Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

#3

It does not happen in safe-mode.

I completely re-installed Atom, so there are no other packages added whatsoever.

Just now, I found an old reference to “atom --disable-gpu”. Tried that and that is also ok.

Mark