Atom crashing after searching directory


#1

After performing a search (search in directory) when the search as completed and results are returned, clicking on any of the entires (or double clicking thinking it would open) causes Atom to basically crash (have to quit app).


#2

Does this happen when you completely close Atom and reopen it from the command line with atom --safe?


#3

I have left the office, I will try this tomorrow morning and update.

Thx for quick reply…


#4

Well, if the behavior reliably happens in normal mode but not in safe mode, then the problem is definitely one of the packages you have installed.

When you get back to your office, please also include the version of Atom and your operating system.


#5

Hey There

So, I tested using atom —safe and the functionality works as expected. Now I have to track down which of my myriad of plugins is causing the problem.

Sigh

    • mse

#6

What version of Atom and what OS are you using? If you’d like to share a list of all your packages with us, the easy way is to use the command apm ls.


#7

OK, here you go :slight_smile:

Running Atom 1.9.2 on OS X (Yosemite)

Plugins

e[36mBuilt-in Atom Packagese[39m (89)
├── about@1.5.2
├── archive-view@0.61.1
├── atom-dark-syntax@0.27.0
├── atom-dark-ui@0.51.0
├── atom-light-syntax@0.28.0
├── atom-light-ui@0.43.0
├── autocomplete-atom-api@0.10.0
├── autocomplete-css@0.11.1
├── autocomplete-html@0.7.2
├── autocomplete-plus@2.31.0
├── autocomplete-snippets@1.11.0
├── autoflow@0.27.0
├── autosave@0.23.1
├── background-tips@0.26.0
├── base16-tomorrow-dark-theme@1.1.0
├── base16-tomorrow-light-theme@1.1.1
├── bookmarks@0.41.0
├── bracket-matcher@0.82.1
├── command-palette@0.38.0
├── deprecation-cop@0.54.1
├── dev-live-reload@0.47.0
├── encoding-selector@0.22.0
├── exception-reporting@0.38.1
├── find-and-replace@0.198.0
├── fuzzy-finder@1.3.0
├── git-diff@1.1.0
├── go-to-line@0.31.0
├── grammar-selector@0.48.1
├── image-view@0.58.0
├── incompatible-packages@0.26.1
├── keybinding-resolver@0.35.0
├── language-c@0.52.1
├── language-clojure@0.21.0
├── language-coffee-script@0.47.0
├── language-csharp@0.12.1
├── language-css@0.36.2
├── language-gfm@0.86.0
├── language-git@0.13.0
├── language-go@0.42.0
├── language-html@0.44.1
├── language-hyperlink@0.16.0
├── language-java@0.22.0
├── language-javascript@0.119.0
├── language-json@0.18.0
├── language-less@0.29.3
├── language-make@0.22.2
├── language-mustache@0.13.0
├── language-objective-c@0.15.1
├── language-perl@0.35.0
├── language-php@0.37.0
├── language-property-list@0.8.0
├── language-python@0.45.0
├── language-ruby@0.68.5
├── language-ruby-on-rails@0.25.0
├── language-sass@0.52.0
├── language-shellscript@0.22.3
├── language-source@0.9.0
├── language-sql@0.21.1
├── language-text@0.7.1
├── language-todo@0.28.0
├── language-toml@0.18.0
├── language-xml@0.34.8
├── language-yaml@0.26.0
├── line-ending-selector@0.5.0
├── link@0.31.1
├── markdown-preview@0.158.0
├── metrics@0.53.1
├── notifications@0.64.1
├── one-dark-syntax@1.2.0
├── one-dark-ui@1.3.2
├── one-light-syntax@1.2.0
├── one-light-ui@1.3.2
├── open-on-github@1.2.0
├── package-generator@1.0.0
├── settings-view@0.238.0
├── snippets@1.0.2
├── solarized-dark-syntax@1.0.2
├── solarized-light-syntax@1.0.2
├── spell-check@0.67.1
├── status-bar@1.4.0
├── styleguide@0.46.0
├── symbols-view@0.113.0
├── tabs@0.98.0
├── timecop@0.33.1
├── tree-view@0.208.0
├── update-package-dependencies@0.10.0
├── welcome@0.34.0
├── whitespace@0.32.2
└── wrap-guide@0.38.1

e[36mCommunity Packages (73)e[39m /Users/mikeerickson/.atom/packages
├── Sass-Syntax-Highlight@0.1.1
├── advanced-open-file@0.16.3
├── aligner@0.22.1
├── aligner-css@1.2.0
├── aligner-scss@1.1.0
├── alignment@1.1.5
├── angular-bootstrap@0.1.7
├── angular-restful-snippets@0.14.0
├── angularjs@0.3.5
├── angularjs-snippets@0.10.18
├── atom-alignment@0.12.1
├── atom-angular-material-snippets@1.2.0
├── atom-beautify@0.29.10
├── atom-material-ui@1.3.3
├── atom-terminal@0.8.0
├── autoclose-html@0.23.0
├── autocomplete-modules@1.5.2
├── autocomplete-sass@0.1.0
├── cobalt2-syntax@0.3.2
├── code-peek@1.4.8
├── color-picker@2.2.2
├── config-import-export@0.3.1
├── css-snippets@0.9.0
├── dash@1.6.2
├── duplicate-line-or-selection@0.5.0
├── editorconfig@1.4.1
├── emmet@2.4.3
├── es6-snippets@0.3.0
├── expand-region@0.2.4
├── file-icons@1.7.17
├── flexbox-snippets@0.3.0
├── fonts@1.6.0
├── gist-it@0.9.1
├── git-control@0.8.2
├── git-plus@5.16.2
├── git-time-machine@1.5.3
├── highlight-selected@0.11.2
├── imdone-atom@1.3.29
├── indent-guide-improved@1.4.9
├── javascript-snippets@1.2.1
├── jumpy@3.0.3
├── language-applescript@0.2.2
├── linter@1.11.14
├── linter-csslint@1.3.2
├── linter-eslint@7.2.4
├── linter-js-yaml@1.2.5
├── linter-less@2.6.0
├── linter-sass-lint@1.7.0
├── linter-stylelint@3.1.0
├── lodash-snippets@1.1.2
├── merge-conflicts@1.4.4
├── mocha-test-runner@0.5.1
├── node-debugger@1.7.0
├── open-in-browser@0.4.7
├── open-in-browsers@0.0.19
├── open-recent@5.0.0
├── open-terminal-here@2.1.4
├── pane-jump@0.2.0
├── pretty-json@1.5.1
├── project-plus@0.9.0
├── recent-files-fuzzy-finder@0.2.4
├── recent-projects@0.12.1
├── script@3.8.3
├── simple-drag-drop-text@0.3.1
├── sort-lines@0.14.0
├── split-diff@1.0.3
├── sync-settings@0.7.2
├── terminal-plus@0.14.5
├── todo-show@1.7.0
├── toggle-quotes@1.0.0
├── tree-view-git-status@1.1.0
├── wakatime@6.0.10
└── wordcount@2.6.2

└── (empty)