Atom crashes when current file in buffer is overwritten/updated


#1

Operating system is OSX 10.11.5, version of atom is 1.8.0. When I viewing a text file and I update it outside of the atom text editor (overwrite it), the whole atom window freezes and becomes unresponsive, so I have to quit/terminate the program.


#2

I can’t replicate this behavior using Atom v1.8.0 on Mac OS X 10.11.5. Here’s what I did:

  1. Launch Atom with my Atom repository open
  2. Open the README.md file
  3. Switch to Terminal
  4. Type cd ~/Source/atom to switch to my Atom repository
  5. Type echo "TEST" >> README.md

This tests the “updated” part. Change the last step to echo "TEST" > README.md to test the “overwritten” part. Neither results in a lockup or crash of Atom for me.

If you have steps that can reliably reproduce the problem for you, please let us know.


#3

Hey leedohm,

Thanks for the quick reply. I can give that a try, but it occured to me after reading up on some related threads that the issue might have something to do with this file (that I’m modifying) being inside of a folder within a git repo that is itself not a git repo. Sounds like a similar issue described in this thread: Atom.io freezes up a lot on file change. Also crashes every time it’s side by side in windows 10. Let me know if you think this isn’t the issue and I can try what you suggested.


#4

I’m not sure what this means. Do you mean that if ~/Source/foo is the root of a Git repository that ~/Source/foo/bar.txt would work but ~/Source/foo/baz/bar.txt would crash? If so, that is also easy to test:

  1. Launch Atom with my Atom repository open
  2. Open the src/scan-handler.coffee file
  3. Switch to Terminal
  4. Type cd ~/Source/atom/src to switch to the src directory inside my Atom repository
  5. Type echo "TEST" >> scan-handler.coffee
  6. Type echo "TEST" > scan-handler.coffee

This also does not result in a lock or crash.

What I need in order to help is a specific set of steps that I can follow to reproduce the problem. Even if it isn’t 100% reliable, it would be a huge help if you could say “do X, Y and then Z and 20% of the time Atom crashes”. I’ll happily take the time to try something (reasonable :grinning:) ten or twenty times over to see if I can get a bug to reoccur.

Speaking of which, have you tried Safe Mode? To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom with the command atom --safe

If a problem doesn’t happen when you’re running in Safe Mode, it is almost assuredly due to a package you have installed. I suspect this is the most likely case given what you’re describing.


#5

People have noted similar issues with Webpack, when the files being packed into are open in the editor. I’m speculating, but it could be a question of volume (though that doesn’t make sense with my understanding of how it works).


#6

I did verify a couple months back that I could get Atom to crash if I created and deleted the file that Atom had open 2 million times over the space of about 4 seconds. If that’s what we’re talking about here, that would be useful information :grinning:


#7

Hey,

I launched Atom from your git repo and didn’t get any error or freezing-up behavior when I tried what you suggested on the ~/Source/atom/src/scan-handler.coffee file. I also repeated what I was doing yesterday, but still using the Atom program launched from your git repo, overwriting the file in the same process that seemed to cause the program I downloaded yesterday to freeze. This time (with my own input file from yesterday) the Atom program lagged for a few seconds, but then began responding to my mouse a few seconds later.

I haven’t tried the safe mode, but I also haven’t installed any packages.

Let me know if there’s any other details I can provide to help. For now, I guess I’ll delete my other copy of Atom and launch from your git repo.


#8

Try Safe Mode anyway, it does more than just not loading community packages.

How big is the file you’re overwriting? Is there anything else about the file that is different from the ones I suggested?


#9

The file I was working with (and similar files) was 0.5 - 1 MB. Where can I find the “atom” executable? I launched from your git repo by navigating to ~/Source/atom/ and then typing “./atom.sh”.


#10

What I meant by “launch from the Atom repository” is to launch an installed copy of Atom and open the repository as a project. I was running an installed copy of Atom v1.8.0 like you were. Running a built copy of Atom is not something I recommend as a debugging step. It might cause more problems than it solves.


#11

I managed to reproduce this on OSX 10.11.6, atom 1.10.2:

$ touch test.txt
$ atom -safe test.txt

That terminal is now tied up with the atom safe mode process, so in a new terminal:

$ for i in $(seq 1 10); do echo $i >> test.txt; done

This works, and the result is immediately displayed in atom. However, if I up the ante slightly

$ echo foo > text.txt
$ for i in $(seq 1 10000); do echo $i >> test.txt; done

atom completely freezes for a full 30 seconds on my machine. I also tried a test with 100,000 lines, and it hadn’t recovered after five minutes – so I killed it. Interestingly enough, the same problem occurs if I generate a large file, then overwrite it with a small one:

$ for i in $(seq 1 10000); do echo $i >> anothertest.txt; done
$ atom -safe anothertest.txt
$ echo foo > anothertest.txt

This problem only occurs for me when the file is open in one of the panes. If for example:

$ touch text.txt anothertest.txt
$ atom -safe test.txt
$ for i in $(seq 1 10000); do echo $i >> anothertest.txt; done

Then open anothertest.txt in atom from the sidebar or cmd+t, there is no delay.

Hope this helps!


#12

@zpolygon95 There is an open Issue for this behavior here:


#13

Thanks, I missed that issue.