Atom crash if no internet


#1

hi all
today I was out my office and I’ve tried to open atom but each time it closes suddenly.

after I found an internet connection and it opens right…

the version is 0.127.0


#2

Can you try and open atom without internet connection, but using atom --safe (disables all packages)?

Atom itself should not require an internet connection. But who knows what any of the packages you may have installed require.


#3

I just tried without connection and couldn’t reproduce the crash, it definitely looks like a package issue, or maybe something related to the OS (BTW, which OS are you using?)


#4

i’m under windows… I try to load with --safe


#5

Just to be clear, safe mode disables all packages that are not installed by default, i.e. it doesn’t load any packages in the ~/.atom/packages or ~/.atom/dev/packages directories. It also doesn’t run your init.coffee script.


#6

Ah, I didn’t know that. I thought it removes practically all packages, but come to think of it… that would render Atom entirely useless. Good point.


#7

tried with --safe but crashes… :frowning:


#8

Is there any error output in the terminal when running atom -f?


#9

nothing (i’m on windows, but on cmd windows no message appears)


#10

When exactly does it crash? Right after launching (again in safe mode), or only after a certain action?


#11

after launch, safe mode or not is the same.
atom appears for a second or less and after closes


#12

I suspect this dude:


#13

noooooooooo this dude no!! :cry:


#14

Thanks, I had that problem here too, i never thought it was a related to internet access. After reading your post, I added atom.exe to the rules of the windows firewall and that solved it. I also added node.exe to download packages.

There’s some other peoples with a crash just after starting chrome here: https://github.com/atom/atom/issues/2969


#15

I use three different O.S.
One them is windows 7x64 with them, i solve the problem with ATOM version 1.1.0 (latest), applied the “npm install” on all installed packages files individually and updating its facilities

Another thing… declared the ATOM complete path from the atom.exe in the Environment System Variables path. These procedures this solves it too.

Other solution, but ugly…is… simple and fast is return to version 1.0.19 and whait the new stable version…but is a lazy solution :frowning: