Atom converting tabs to spaces


#1

I have been using Atom as my defacto editor for pretty much anything… I recently discovered something that its either a bug or maybe I am doing something wrong.

When I type some text and I hit my TAB key, for some reason it doesn’t treat the space created as a TAB, but as a space and when coding Makefiles, well you get the gist of it…

So how can I configure Atom to not do that or is it that I am doing something wrong?


#2

This behavior is called “soft tabs” and you can disable it in the Settings View at the bottom of the main settings screen.


#3

And if you only want to change this behavior for e.g. Makefiles, check out the overrides package </shameless-plug>


#4

I’ve been using the https://atom.io/packages/tabs-to-spaces package and found it very useful to work around strange atom tabbing behaviour on occasion.


#5

@ioquatix, Tabs to Spaces and Spaces to Tabs is a default functionality and comes build in with atom/whitespace package.


#6

It is now. That functionality was only added recently. And my tabs-to-spaces package still has one piece of functionality that Atom doesn’t have by default … which is automatically tabifying or untabifying on every save, if you want.


#7

I’m actually having this issue still on 0.120.0 with the Soft Tabs option disabled.

If I re-open the project, it goes back to using tabs again, but after a while it seems to revert to using spaces and I have to re-open again.

Very odd and seems quite random. I’ve tried, but I can’t find a hard and fast way to recreate this reliably.